14 Replies Latest reply on Oct 6, 2016 2:37 PM by Intel Corporation

    Intel Core i7 6700k can't update driver, says I don't have the minimun requirements to install.

    rodrigompu96

      Actually it says it in spanish, but basically that, I tried using the intel driver update utility and failed, tried manually using the .exe and .zip and failed. I would like to know what to do.

      The intel driver update utility says that there are no drivers for my product, it doesn't even recognize it.

      However, the Intel processor identification utility shows this:

      Intel(R) Processor Identification Utility

      Version: 5.50.20160527

      Time Stamp: 2016/09/28 16:40:57

      Operating System: 6.2-9200-

      Number of processors in system: 1

      Current processor: #1

      Active cores per processor: 4

      Disabled cores per processor: 0

      Processor Name: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz

      Type: 0

      Family: 6

      Model: 5E

      Stepping: 3

      Revision: 39

      Maximum CPUID Level: 16

      L1 Instruction Cache: 4 x 32 KB

      L1 Data Cache: 4 x 32 KB

      L2 Cache: 4 x 256 KB

      L3 Cache: 8 MB

      Packaging: LGA1151

      Enhanced Intel SpeedStep(R) Technology: Yes

      MMX(TM): Yes

      Intel(R) SSE: Yes

      Intel(R) SSE2: Yes

      Intel(R) SSE3: Yes

      Intel(R) SSE4: Yes

      Intel(R) AES-NI: Yes

      Intel(R) AVX: Yes

      Enhanced Halt State: Yes

      Execute Disable Bit: Yes

      Intel(R) Hyper-Threading Technology: Yes

      Intel(R) 64 Architecture: Yes

      Intel(R) Virtualization Technology: Yes

      Intel(R) VT-x with Extended Page Tables: Yes

      System Graphics: Add-in Graphics

      Base TDP: 95 W

      Expected Processor Frequency: 4.0 GHz

      Reported Processor Frequency: 4.0 GHz

      Expected System Bus Frequency: 100 MHz

      Reported System Bus Frequency: 100 MHz

      *************************************************************

       

      I would like some help, thanks a lot.