4 Replies Latest reply on Sep 30, 2016 1:21 PM by Intel Corporation

    Intel® USB 3.0 eXtensible Host Controller Driver setup fails (WIN7@64)

    dunealex

      Hello support community!

       

      First things first:

      OS: WIN7 64bit (latest updates installed) on Crucial SSD 525GB

      MB: Z170A PC MATE

      RAM: 32GB Corsair 2800

      CPU: i7 6700K @default speed

       

      -I installed the new mainboard and it's drivers. SO far, everything works, apart from my USB devices. Mouse and keyboard are working (barely, they're supported by BIOS and emulated as PS2 devices), but any other device wouldn't.

      -I tried the driver, provided with the board. It fails to install: "One or more devices couldn't be installed. Setup is being aborted." (Support For Z170A PC MATE | MSI Global | Motherboard - The world leader in motherboard design )

      -I got the driver from your website, same result. (Download USB 3.0 Driver: Intel® USB 3.0 eXtensible Host Controller Driver for Intel® 8/9/100 Series and Intel® C220/C610… )
      -I got the driver from Lenovos page, same result. (They're all the same, just other brandings. But you never know.) (Intel(R) USB 3.0 eXtensible Host Controller für Windows 7 (32 Bit und 64 Bit) – ThinkCentre / ThinkStation - Lenovo Supp… )

      -I manually installed the driver to sys32 and WIN auto-searched and found it. When trying to apply the driver, this message will appear: "File couldn't be found."

      -I then manually pointed WIN at the according *.inf file. It takes the driver, but then mouse and keyboard seize to work. Even after reebooting. So I had to restore to a earlier state, which worked fine.

       

      Any help would be appreciated.

       

      Thx in advance!