14 Replies Latest reply on Oct 14, 2016 6:54 AM by Intel Corporation

    Visual Bios - unable to access using F2


      On the NUC D54250WYKH (currently at BIOS 42) ever since BIOS v40 (I think... maybe earlier), I haven't been able to get into Visual Bios.  I would like to add memory to the system, but I hesitate doing so if I can't get into the bios.


      I would be so happy if I could get any Bios screens to appear... I don't need a Visual Bios, the old-fashioned text one was fine.


      This seems to be a VERY common problem and has been for a few years now.  I want to get a second NUC, but worry about having this same problem.


      Upon booting, I press F2 when prompted to enter Setup but the screen just goes black.  Nothing happens.  I try hitting F9 (load defaults) and F10 (save and exit) even though I can't see a screen, but this doesn't help.


      I have tried all the different Intel directions, suggestions from community members and other websites - I've tried:

      1) Connections - HDMI, DisplayPort, DisplayPort to VGA, DisplayPort to DVI

      2) Multiple monitors - old and new

      3) Moving the jumper / power on / off - clearing CMOS

      4) Holding the power button and releasing after the beeps to get longer boot menu

      5) Removing the two SSD drives from the unit and trying the above


      I have a monthly check in my calendar to check the Intel site hoping a new BIOS would fix the problem but no luck.


      What else can I do?