1 2 3 4 Previous Next 53 Replies Latest reply on Mar 9, 2017 8:55 AM by cvare Go to original post
      • 30. Re: NUC6i3SYH sd card slot is not working
        GregL

        Sorry.... I have the same configuration, tried the workarounds. Right after the '496 windows update it appeared that the SD reader was functioning. But after rebooting the machine it didn't work any more. What is worse, when it did work I could read a 1gb SD card but a much larger 128gb microSD card in a carrier beeped (the computer, not the SD card) when it was inserted or removed but explorer would not see it. Also, by trying the disable/enable trick I could get the card to be recognized, but all the files transfered to it were corrupt. Not an issue with the card itself -- my Win7 laptop can read/write with no problems.

        • 31. Re: NUC6i3SYH sd card slot is not working
          cvare

          Thanks for the update GregL, I'm not sure what you mean by the '496 Windows update.

           

          Just to clarify, what we've found is that if using Windows 10 Anniversary Update, you should update your BIOS to version 0052 and make sure Windows version is 14393.222 or later.

           

          There have been reports of some larger SD Cards not working, but smaller ones should work just fine.

          • 32. Re: NUC6i3SYH sd card slot is not working
            GregL

            Sorry... it is the KB3194496 cumulative update for Windows 10 version 1607 - os build 14393.222.

            When I first got the NUC I ensured that it was current -- is there a way of verifying BIOS level from the OS?

             

            thanks,

             

            greg

            • 33. Re: NUC6i3SYH sd card slot is not working
              GregL

              Followup... checked bios level, was at 0042, so installed the 0052 update. This did make a small change in how things behave. If I insert a 1gb SD card, the system beeps and opens an explorer window. If I insert a 128gb SD card, I get the beep but the card is otherwise invisible/inaccessible. No explorer window opens and the device is not added to the PC directory view.

               

              greg

              • 34. Re: NUC6i3SYH sd card slot is not working
                cvare

                Can you access your 1GB card, or does an empty window open?

                 

                What brand is your 128 GB card?

                • 35. Re: NUC6i3SYH sd card slot is not working
                  GregL

                  The non-functioning SD card is a Samsung 128gb EVO plus micro-SDXC UHS-1 card in the provided SD adapter. This card works fine in my Lenovo SL-510 laptop running Win7x64.

                   

                  The smaller card is a Lexar 1gb SD card. And yes, I just get an empty window. Also, when I ask explorer to do a refresh it just hangs. After that there are no more mount/dismount beeps. However, about 5 minutes later something seemed to wake up and I got a mount beep (the card had been left in the slot). I was able to read/write to the card as normal.

                   

                  g

                  • 36. Re: NUC6i3SYH sd card slot is not working
                    cvare

                    Sorry for the late reply.  Been sick and then took some time off.

                     

                    Thanks for the info, I'm sending this to the engineering team to investigate.

                    • 37. Re: NUC6i3SYH sd card slot is not working
                      cvare

                      Guys I have some bad news.  We purchased both a Kingston 128 GB SDXC U3 UHS-I and Samsung 128 GB EVO plus micro SDXC UHS-1 SD Card and both of them work just fine for us.

                       

                      It was tested on Windows 10 RS1 with OS Build 14393.222 and BIOS version 0052.

                       

                      Any chance you've done a BIOS recovery?  I suggest trying that, it may help.

                       

                      BIOS Recovery Update Instructions for Intel® NUC

                       

                      Also, can you tell me your exact setup?

                       

                      What ssd, ram, what's connected, etc.   Since we just use a nuc with nothing connected to it, per chance something is interfering?

                      • 38. Re: NUC6i3SYH sd card slot is not working
                        GregL

                        I read the link you provided for the BIOS recovery.... if the BIOS updates have applied correctly, why would I ever want to do this? And besides, watching the update process run, what would this touch that the update does not already overwrite? The other item is that I am running Win10, only saw entries for 7, 8, 8.1 and other. Not sure this really helps or why.

                         

                        As for the configuration, I am running a NUC6i3SYH with 32gb ram, Intel SSDCKKW240H6 and Kingston SHSS37A240G boot device.

                        Wired ethernet, bluetooth enabled for audio headphones, Wired keyboard and trackball, 2 monitors on HDMI and microHDMI adapters. I also have the driver installed for a WD Nas on the wired network (gigabit), reluctant client on Win 2012 essentials server domain, run local Hyper-V.

                         

                        I would observe that Win10 continues to have issues with Explorer -- especially network attached devices, file shares. I would not be the least bit surprised if the problem were Microsofts... since the OS appears to recognize the device, then fails to connect and display things properly.

                         

                        greg

                        • 39. Re: NUC6i3SYH sd card slot is not working
                          cvare

                          Re: the BIOS recovery.  I agree, everything should be fine, but every once in a while weird things can happen, like the ME can get corrupted.  If that happens, the only way to fix is by a recovery.  Just a suggestion.

                           

                          Not sure I understand the Win 7, 8.1 comment.  The link I shared on how to recover the BIOS is OS agnostic.

                           

                          Yeah, it's sometimes really hard to tell.  We certainly had an issue where the CPU would shoot up when you inserted the card, but once we fixed that, Microsoft was the culprit when it came to not seeing the cards. 

                           

                          We'll keep doing some testing, but please let us know if anything changes, and we'll do likewise.  Thanks Greg.

                          • 40. Re: NUC6i3SYH sd card slot is not working
                            GregL

                            Fine. I did the BIOS recovery to a newer version of the bios - 054. Interesting effects -- the 1gb SD was recognized immediately. The 128gb that I had used on an Android device was recognized, but Win insisted there was a problem with it, but when it went to 'fix' it said there was nothing wrong -- then Explorer opened the device. So I put the other unused 128gb in... nothing. Then, a couple of minutes later, it asked that I insert a disk into the drive. So I pulled it out and re-inserted it. File Explorer just opened but it is blank. Device manager says its working properly. But if I ask it to populate the volume tab it goes away... and hangs. And was unkillable... Looks like I have to bounce the box to shut it down.

                            • 41. Re: NUC6i3SYH sd card slot is not working
                              GregL

                              After the box restarted, I was able to use the 1gb and 128gb SDs with no apparent issue... unless something changes, I guess this will have to be marked 'resolved'... although I think we would both prefer it to be 'solved'.

                               

                              greg

                              • 42. Re: NUC6i3SYH sd card slot is not working
                                cvare

                                Agreed, don't like leaving it up in the air like this. 

                                 

                                Thanks for the feedback Greg, please let us know if something changes.

                                • 43. Re: NUC6i3SYH sd card slot is not working
                                  cvare

                                  Greg, we were able to see that there is an issue with some Kingston cards-still working on a solutions-is your Samsung card still working?

                                  • 44. Re: NUC6i3SYH sd card slot is not working
                                    GregL

                                    Thanks for asking. Since I declared that it was working there have been a few more waves of MS Updates. I checked it this morning -- the first 128gb mSSD was correctly recognized -- a beep when it mounted, then File Explorer opening up. By chance it was the one I initialized on my Samsung tablet. So I pulled it out and inserted the one with a pile of movies on it. Got the beep but Explorer could not see it. Bad word... Since the first one mounted nicely and the second one failed makes me wonder if someone is not cleaning up properly on exit? Just a thought.

                                     

                                    greg