8 Replies Latest reply on Sep 27, 2016 12:43 PM by Intel Corporation

    RST "unknown error" while enabling acceleration

    Dominicus

      My setup:

      intel DZ68C motherboard with i7-2700k CPU

      Samsung 850 PRO 256GB SSD boot

      Western Digital Black 2TB HDD files

      Intel X25-M G2 80GB SSD cache drive

       

      Win 7 Ultimate 64bit

      RST 11.7.0.1013

       

      SATA is set to RAID, all drives seem to show as expected:

      I head to the "Accelerate" tab and select to accelerate the HDD:

      I get about a minute of the spinning hourglass, and this error:

       

      So far, I've uninstalled/re-installed RST 11.7.0.1013, "Reset to available" the cache drive, reboot, try again, I get same result.

       

      Found a post advising to shrink the volume to be accelerated, leaving ~100MB unallocated, which I did, but still same result.  Here's the disk manager view of my drives:

        • 1. Re: RST "unknown error" while enabling acceleration
          mikec_intel

          Hi Dominicus,

           

          In regards to your issue, could you please provide me with more details of your configuration? According to the pictures, I believe you are accelerating the 2TB HDD (WD) with the 80GB SSD (Intel) and you are using the RST version 11.7.0.1013.

           

          If this is the case, 1-I suggest you to update the RST application to version 12.9.0.1001 (this is the last Windows 7 version of RST). 2-Un-accelerate the 80GB SSD and re-format it. 3-Then, accelerate the RAID configuration, use 100% of the SSD. You can shrink it later.

           

          Regards,

          Mike C

          • 2. Re: RST "unknown error" while enabling acceleration
            Dominicus

            intel DZ68BC motherboard with i7-2700k CPU and Win 7 Ultimate 64bit OS

             

            The drives are connected as follows:

            • SCSI Bus 1: Samsung 850 PRO 256GB SSD boot
            • SCSI Bus 0: Western Digital Black 2TB HDD file storage
            • SCSI Bus 5: Intel X25-M G2 80GB SSD cache drive

             

            I was advised RST 11.7.0.1013 was the latest RST version supported by my motherboard in this post:

            Help re-enabling SRT on DZ68BC motherboard

             

            With RST 11.7.0.1013, the RST GUI will display the [Accelerate] button.  I removed all partitions and reformatted the cache SSD, and updated RST to 12.9.0.1001 as you advised.  RST 12.9.0.1001 is not giving me the option to [Accelerate] anymore.

            It just shows all installed drives:

            The boot SSD and the file storage HDD are connected to the pair of blue 6Gb/s SATA connectors, while the Cache SSD is on a black 3Gb/s SATA connector.

            Could it be SRT can't be enabled between drives on blue and black ports? (i.e. that both cache and accelerated drive need to be using pair of black or blue SATA ports)?

            • 3. Re: RST "unknown error" while enabling acceleration
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi Dominicus,

              The acceleration option is not available. Let’s try with this workaround. Click the Manage icon, and click “Suppress SMART event” it is in blue. The new tab “Accelerate” will show up.

              If the problem continues, make a low format of the Intel X25-M G2 80GB SSD.

              2.jpg

              3.jpg
              4.jpg
              Mike C

              • 4. Re: RST "unknown error" while enabling acceleration
                N.Scott.Pearson

                On your board, for RST and SRT, you must be using only the dark blue (FF) and black (GG) SATA connectors from the PCH. The light blue SATA connectors (EE) are exposed by a separate Marvell IC. For best performance, I recommend that both the Cache SSD and the HDD to be accelerated be plugged into the dark blue SATA connectors. Your System SSD can be plugged into the light blue SATA connectors and booted from there (though this configuration will require inserting the Marvell drivers during the Windows installation process - and will require customization of the Boot Order parameters in the BIOS to force it to boot from the Marvell-based SSD).

                 

                You might want to go into the RST Configuration screen (via CTRL-I) and make sure that all drives are in the non-Member state before attempting to enable SRT.

                 

                Hope this helps,

                ...S

                • 5. Re: RST "unknown error" while enabling acceleration
                  Dominicus

                  I tried unsuccessfully several configurations and RST drivers over the weekend.  Here's my current configuration:

                   

                  • BootSSD and DVD-drive using the pair of light blue "Marvell" ports
                  • 2TB HDD and 80GB CacheSSD using the dark blue intel controller ports
                  • Black SATA ports have no drives
                  • RST 11.7.0.1013 installed on Windows 7 Ultimate 64-bit
                  • BIOS reports intel SATA in RAID mode, and secondary SATA (Marvell), on ACHI mode

                   

                  Operations:

                  • Opened the RST UI, [Accelerate] tab and "reset to available" to remove the RAID partitions on the CacheSSD
                  • Opened Disk Manager, Create New Simple Volume on CacheSSD,
                  • Open Disk Management, asks to initialize Disk0, chose MBR partition style. Don't Assign drive letter, NTFS format, not quick (low level format.  Result: NewVolume is defined.  Restart PC.
                  • Opened the RST UI, no [Accelerate] button.
                  • Open Disk Management, Delete Volume from CacheSSD.  Restart.
                  • RAID oROM reports cacheSSD and HDD as "Non-RAID drive"
                  • Open RST UI, [Accelerate] tab, "enable acceleration" with options full-disk and "enhanced mode":
                    IntelRST_Error_11-7_Accelerate_Screen_3457.PNG
                  • Click [OK], see the cacheSSD show partitioned, Windows notifies new volumes 00001 and 0000 are detected, get the hourglass donut for 30 seconds...
                  • Get error: "An error occurred and the selected disk or volume could not be accelerated.  Please restart your computer, and then try the operation again.": IntelRST_Error_11-7_Accelerate_Screen_3458.PNG
                  • Restart PC, wait until RST tray icon has green checkmark.
                  • Open RST UI, [Accelerate] tab, "select device" link, and select the 1.8TB HDD to accelerate.
                  • Get hourglass donut for 45 secs and error  "An unknown error occurred while an operation was in progress.  The operation could not be completed." IntelRST_Error_11-7_Accelerate_Screen_3459.PNG

                   

                  This is as close as I can come to getting RST to work at enabling acceleration, while isolating the only two drives I wish to accelerate in single controller.

                  • 6. Re: RST "unknown error" while enabling acceleration
                    Dominicus

                    I got the following results for these RST drivers.  The configuration tested was bootSSD on Dark Blue port; HDD, cacheSSD, and DVD-RW on black SATA ports:

                     

                    RST 10.6.0.1022 and

                    RST 10.8.0.1003:

                    • 10.6.0.1022 was the original driver used to setup SRT back in 2012, using the same intel SSD cache disk, and another 2TB HDD as boot drive (both were on dark blue ports).
                    • 10.8.0.1003 driver is saved in my "downloads" folder in the last whole-disk backup done while SRT worked correctly, so my guess is, at some point, I updated the RST driver to this version.
                    • Installing either of these two drivers produces the same result:
                    • [Accelerate] button is visible, click [accelerate], app flickers and now displays the cacheSSD with partitions, but acceleration is not enabled:IntelRST_Error_11-7_Accelerate_Screen_3446.PNG
                    • Clicking on "select device" allows to again specify the HDD to be accelerated but nothing happens
                    • I repeated these test with cacheSSD and HDD on dark blue ports, while bootSSD and DVD-RW on Marvell ports, with RST 10.8, got same result.

                     

                    RST 14.8.0.1042, 12.9.0.1001, RST 12.8.0.1016, RST 12.5.0.1066, RST 12.0.0.1083:

                    • These drivers will not show the [Accelerate] button
                    • I repeated the test with cacheSSD and HDD on dark blue ports, while bootSSD and DVD-RW on Marvell ports, with RST 12.9.0.1001, got same result, no [accelerate] button.
                    • 7. Re: RST "unknown error" while enabling acceleration
                      Dominicus

                      I was finally able to enable acceleration.

                      I had read about SRT needing the main partition shrunk to create unallocated space (which I had tried), I didn't realize the requirement was for the unallocated space to reside at the very end of the disk.

                      Since my HDD used to be my boot drive, there was a 450MB recovery partition created by OS at the end of the drive, one that Windows Disk Management wouldn't allow me to edit.

                      I installed the free EaseUS partition SW, and moved/resized the defined partitions such that 100 MB at the start of the drive, and 200 MB at the end of the drive, remained unallocated.  This SW took its sweet time, but succeeded.

                      Opened RST UI, Accelerate button, and selected the HDD to get accelerated...success!

                      After acceleration was enabled, the unallocated space at the end of the drive went from 202MB down to 193MB.

                      RST apparently needed to find 8MB of unallocated space at the end of the drive to be accelerated so it can save it's magic bits.  A more meaningful error message than "unknown error" would've been good to have.

                      • 8. Re: RST "unknown error" while enabling acceleration
                        Intel Corporation
                        This message was posted on behalf of Intel Corporation

                        Hi Dominicus,
                         
                        Thank you for your update. I am glad you were able to accelerate the volume.
                         
                        Mike C