1 2 Previous Next 26 Replies Latest reply on Sep 23, 2016 6:53 AM by Intel Corporation

    RAID corruption

    FKA

      Hi everyone,

       

      we encounter some issues with embedded intel RAID.

       

      Descripition of the problem :

       

      - we put 3 WD Red HDD in the PC

      - we create a RAID5 volume on the three disks

      - we install Windows Server 2012 R2

      - after the first or second reboot of the OS

      •      either the system hang on the RAID summary interface

                - some times is pass by this screen and Windows fails loading with BCD error

                - some times we need to power reset the system and get an "Error Occured (0)"

      •      or we have one drive having "Error Occured (0)"

       

      Same happens when we try with RAID 1

       

      Mobo: Jetway NF9J-Q87

      CPU ; i5 4690

      RAM : Corsair 16Gb

       

      Intel ROM version : 12.6.0.1867

      Intel RST version : 13.6.0.1002

       

      Edit : no need to wait for windows installation. If we just configure the RAID, reboot few times, it becomes corrupted with a disk either "Error Occured" or "Non RAID disk".

      Edit 2 : Everything is fine with WD RE4 1TB / WD Red 1TB. So far the problem is with Red 4TB. We are currently testing Red 2TB

       

      Any advice ?

       

        • 1. Re: RAID corruption
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello FKA ,
           
          Thank you for joining the Intel communities.
           
          Would you please POST a picture when you get the issue so we can get a better vision of the problem.
           
          According with this website http://www.jetwaycomputer.com/NF9J.html this motherboard has not been tested with Windows Server 2012 R2, have you tried with another Windows version to see if it works just to isolate the issue.
           
          Regards,
           
          Ivan
           

          • 2. Re: RAID corruption
            FKA

            Hi Ivan,

             

            As said in my first edit, the problem occur event before installing any system so the system is not the problem.

            I configure the BIOS either on RAID 1 or RAID 5, save, reboot the system once or twice and then the volume is corrupted.

             

            The issue occur with : WD Red 4TB

            But not with : WD Red 1TB / WD RE4 1TB / WD RE4 2TB

             

            So I suspect something beetween the BIOS and the drives (firmware configuration, too old oprom, ...)

             

            Here is one screenshot.

            I had configured a RAID 5 on disk 0 / 1 / 2. Disk 3 is a spare disk.

            Rebooted the system, et voila !

            DSC_0002_5.JPG

             

            I've also posted on WD support forum : Issue with Intel RST - Desktop & Mobile Drives - WD Community

            And requested help from Jetway.

            • 3. Re: RAID corruption
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Thank you for clarifying that to us.

              It seems that the Meta data on that disk has been corrupted and therefore it has been taken out of the RAID volume.

              I’m not sure if you have the latest BIOS version for this motherboard but you can try updating the bios to the latest version if it is not updated, then reset disks to Non-Raid and try to create the RAID again.

              If that does not work, the cable on that port or the port itself may have issues.

              Also, you can try to set the bios to default settings and then try again, you will need to set the bios to RAID again before trying to create the raid.

              Regards,

              Ivan

              • 4. Re: RAID corruption
                FKA

                Thanks Ivan but:

                 

                - the BIOS is the latest one

                - the BIOS has been resetted to default

                - we checked every bios options to find a solution

                - the cables have been changed

                - we tried with another motherboard (same model)

                - we did multiple RAID reset, RAID recreate operations

                - the RAID is working with other model of HDD

                 

                I suspect a complicated issue there.

                • 5. Re: RAID corruption
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  In this case, you can wait for WD to reply back to you, but I suspect an issue with your hard drive and not the bios or anything else because the RAID shows as failed, meaning that one or more hard drives have failed.
                   
                  I suggest you to get a replacement for the hard drive.
                   
                  Regards,
                   
                   
                  Ivan
                   

                  • 6. Re: RAID corruption
                    FKA

                    Thanks Ivan,

                     

                    the problem is that it is not always the same drive that is in error.

                    Moreover the drives have been tested any so far they seem OK individually.

                     

                    I really don't know what to think about it

                    • 7. Re: RAID corruption
                      Kbird

                      AFAIK  WD RED Drives are designed for Use in NAS's NOT for Raid Array's, ( Raid is supposedly support in a NAS though with NAS3)

                       

                      Specs:  Fill it with seasons 1-9. Fill it with .RAW photos. Fill it with WD Red.

                       

                      In the Case of the 4TB I would suspect that perhaps TLER is the ISSUE in those drives and they are dropping out of the Array after a timeout, which means you have to rebuild it all the time.

                       

                      This was an Issue years ago with their Black Drives too ,which could be fixed with WTLER.exe but that has not worked since 2009 AFAIK.

                       

                      TLER feature on RAID Edition drives cannot be disabled | WD Support

                       

                      Support for WD desktop drives in a RAID 0 or RAID 1 configuration | WD Support

                       

                      The WD RE drives are Raid Certified so are ok AFAIK......

                      • 8. Re: RAID corruption
                        LemonComputers

                        Kbird wrote:

                         

                        AFAIK WD RED Drives are designed for Use in NAS's NOT for Raid Array's, ( Raid is supposedly support in a NAS though with NAS3)   Specs: Fill it with seasons 1-9. Fill it with .RAW photos. Fill it…

                        The WD Reds are designed for NAS usage however they should work fine with non-NAS RAID and can even be used as a desktop drive.

                        • 9. Re: RAID corruption
                          FKA

                          @Kbird

                          AFAIK  WD RED Drives are designed for Use in NAS's NOT for Raid Array's, ( Raid is supposedly support in a NAS though with NAS3)

                           

                          This is interresting.

                          With my limited knowledge of the subject, as the PC will be mainly used as a 24/24 file server, I thought it was wise to use Red drives.

                          Does this mean that Intel Raid is not at all similar to what a NAS does for RAID ? Indeed, I also have 4TB WD Red in a synology and they perform well.

                          Can you give me fwe keywords that could allow me to dig this subject ?

                           

                          BTW, I've checked the TLER, it's the same for the Red drives (failling) than for the RE4 drives (working) [Read 7sec / Write 7 sec]

                          • 10. Re: RAID corruption
                            Kbird

                            I admit my knowledge of RED Drives isn't that Current I have 6x 2TB versions 2-3 yrs old but none are in RAID , not all NAS's use RAID , but I use two as BACKup drives in my desktops, no issues there either.  WD used to only support Raid0/1 with the Blue, Black and Green Drives , you used to have to use enterprise grade drives for 24/7 File Servers but that may not true today , I have had good luck with WD Drives for many yrs , so I have not had to do alot of Research lately.

                             

                            How did you check TLER ?

                             

                            The problem in the Past was with certain Models of the Black Drives , eg the 640 GB model went through a number of changes and some didn't have TLER enabled (or it was set too Short ? )  and they would drop out of the Array , causing a rebuild. 

                             

                            And your issue sounded similar which is why i mentioned it , in case the 4TB model does not have it , or it is set incorrectly , I would certainly ask on the WD Forums or at Websites like StorageReview on their Forums

                             

                            StorageReview.com - Storage Reviews  

                             

                            WD Red 4TB HDD Review (WD40EFRX) | StorageReview.com - Storage Reviews

                            • 11. Re: RAID corruption
                              FKA

                              I checked the TLER using the smarctl utility from https://www.smartmontools.org/ . I came across that tools during my research for a solution.

                               

                              I'll have a look at storage review to see if I find something.

                              In the meantime, I got suggestions from the guys at win-raid.com.

                              I'll may try updating my system's UEFI firmware to get a better version of the opROM.

                              • 12. Re: RAID corruption
                                Kbird

                                I thought perhaps you had found a program other than SmartCtl  that I was not aware of.

                                 

                                The guys at Winraid , know their stuff , but Modding a UEFI is not for the faint of heart    , so they don't think the 4TB RED not having TLER is the issue?

                                 

                                I have an open Thread there too about my 3 disk WD Black Array showing as SSD's instead of HDD's , it has been an issue for over a year apparently accord to this intel thread ......this is why i was here on the forums actually and saw your question.....

                                 

                                Intel RST installation incorrectly sets hard drive media type Windows 8.1 Pro x64 

                                • 13. Re: RAID corruption
                                  FKA

                                  The TLER subject didn't come in the conversion.

                                  I'm gonna ask.

                                   

                                  Should you want to see my thread there : RAID Performance » RAID Crashing - NULL performance

                                   

                                  Crazy how something that should be binary lead to such random ouput :-) too many layers of binary i guess.

                                  • 14. Re: RAID corruption
                                    Kbird

                                    I did see your Post there actually ( ELM)   I always use Fernando's "Best Driver" from the table at the bottom of the 1st post on his page (Below) that is appropriate for my Chipset. I have followed it since Nvidia did chipsets ...so awhile now 

                                     

                                    Which are the "best" Intel AHCI/RAID drivers?

                                     

                                    I see he ignored the TLER issue ..... but I see it IS working on the 4TB RED, I thought it wasn't above ...

                                     

                                     

                                    He thinks I should reinstall Win10AU to cure my problem....we will see....

                                    1 2 Previous Next