4 Replies Latest reply on Feb 3, 2010 12:10 PM by MarkJohnson

    Help, new to Intel SSD.

    MarkJohnson

      Sorry, I have a ton of questions I couldn't find an answer to all of them and some seemed to have conflicting posts.

       

      I have a 4 drive setup.  They are all IDE mode.

       

      I replaced one with my new X25-m G2 160GB SSD. I unplugged the sata cables to all other drives then I download and installed the latest firmware then I installed Win 7 Ult x64.  I messed up and didn't enable AHCI before installing windows and found a regiedit patch to enable AHCI in windows and it rebooted after setting AHCI in the BIOS.

       

      After updating windows I decided to connect my other drives, but the BIOS would clear.  it kept hanging on drive detection.  Do I need to backup/restore/ format AHCI all my drives before the BIOS will clear them?

       

      Will I need to reformat my SSD in AHCI mode as well?  It boots fine, but will it work better reforatting in AHCI?

       

      Do I need to install the IMSM?

       

      Do I need to enable trim?  or will it auto-detect I'm now in AHCI and enable it for me?

       

      Do I need to install the toolbox software?  or is that for non-trim users only?

       

      Sorry for the ton of messages, but search was overwhelming, and was just confusing me.

      -=Mark=-

        • 1. Re: Help, new to Intel SSD.
          Ozz

          I'm assuming you're runing an intel setup here...

           

          - Which motherboard, which BIOS revision?

          - Which ports on the motherboard are you connecting the drives to?

          - What Intel RAID/AHCI BIOS is reported? (just after  the BIOS POST screen, you should get the AHCI intialisation. Given you said its freezing, just leave the others disconnected if you mean its freezing on the BIOS part of detecting HDDs in order to get to the AHCI intialisation screen and report the version.)

           

          Don't install IMSM if you want TRIM. Current version doesn't support TRIM. but the new Intel Rapid Storage Technology drivers apparently do, and aren't far from release. Just use default Microsoft AHCI driver for now.

           

          Now youre using AHCI driver, it will be passing the TRIM commands, so you don't need to do anything.

           

          Toolbox software is not needed, but you can still install it to check the status of the drive and run diagnostic tests.

           

          Since you were using the drive in IDE mode previously, my understanding of the literature is that TRIM wasn't enabled during this time. Hence, you're probably better off installing the toolbox and running a manual TRIM. From this point onwards though under the Microsoft AHCI driver, TRIM should be taken care of. (thought: after a week or two's use, run another manual TRIM and compare it against the time taken the first time. Theoeretically it should perform the task VERY quickly since the OS has been maintaining TRIM during this time.)

          1 of 1 people found this helpful
          • 2. Re: Help, new to Intel SSD.
            MarkJohnson

            I have an evga x58 sli LE motherboard, and newest BIOS (11/06/09)

            I have SSD on port 4, the others on 1,2,3 plus a DVD and eSATA on ports 5 & 6.

            AHCI Option ROM is V01.06.70, but it never clears the BIOS detection and never gets to the AHCI screen.

             

            I'm using the msahci right now and will continue until final release of RST.

             

            Is there a way to check if TRIM is enable or not?  I thought I read about it somewhere, but forgot to save it.

             

            Maybe I'll install the toolbox just for monitoring, if nothing else.

             

            Thanks for your very helpful reply

            -=Mark=-

            • 3. Re: Help, new to Intel SSD.
              Ozz

              that's weird.. i have a suspicion that your board has a JMicron controller judging by that version string. Do you see "© Intel 200x" or similar anywhere on the same screen as the AHCI version?

               

              If that is the case, I wouldn't be surprised if you're having detection issues.

               

              In regards to checking if TRIM is operational, I don't think so directly     , unless through benchmarking or waiting a while to see if you get really slow write performance later on.

               

              Perhaps doing a manual TRIM later on to see if it takes (a) short amount of time indicating there was nothing to TRIM because the OS has been taking care of things or (b) a long time to do indicating that perhaps TRIM isn't working, may be a way to confirm it is indeed working.

              • 4. Re: Help, new to Intel SSD.
                MarkJohnson

                That is all that is printed.  When it shows the drive being deetected, it flashes so fast I can't read a thing.  So, I'm not sure if more info is given after detection or during detection.

                 

                also, my drives hanging are for my other motherboard.  It is an Asus P5QL Pro and it does have a Marvell controller that is disabled(it is a P43 with ICH10).

                I now get absolutely nothing on the AHCI screen.  It is blank with a blinking underscore cursor for a few seconds before it boots into windows.

                 

                It has slowed down my system by enabling AHCI by a lot.  for  example, shutting down took maybe 4 seconds and now takes over 10 seconds.

                 

                I have the latest BIOS (1004).  I do have it overclocked, so maybe I'll try to reset to defaults and hope for improvements.

                 

                Thanks a ton for your help and sorry for not clearing up I use two motherboards.

                -=Mark=-