9 Replies Latest reply on Sep 21, 2016 12:44 AM by Intel Corporation

    Upgrading I350-T2 driver from v12 to v21 causes 2012R2 to bluescreen!

    OvalPiston

      I'm currently running an I350-T2 NIC in a Windows 2012 R2 server with a Z68 chipset. I have two switches for the network, and each port on the I350-T2 is plugged into one of the two switches.

       

      The current driver version is 12.14.7.0 with a date of 6/18/2015.

       

      I want to team these connections so the appear as one IP and so I can do link aggregation. I am running Hyper-V so I need to do this so I can create an External Virtual Switch in Hyper-V.

       

      Question 1: When I open the properties of one of the network adapters on the I350-T2 NIC and go to configure the NIC to create a team, the wizard goes through to the end and then simply says "Create team failed." No error message, nothing. What is the problem?

      Question 2: I downloaded the latest version, v21, from the intel download page. When I run the installation, the server blue screens! I have tried it two times and it has bluescreened the once and the second time it just locked the computer and rebooted!

       

      Is there something I'm missing for how to install the latest drivers for these cards?