2 Replies Latest reply on Sep 13, 2016 1:45 PM by Intel Corporation

    NUC5PPYH not powering ON


      I have a NUC5PPYH purchased in India on August 2, 2016.


      When I tried to power it ON on Sep 10th , it did not power ON. Both Power LED and HDD LED remained OFF.


      The internal green LED turns ON and turns OFF after a few seconds. The fan spins up for a few seconds and then turns OFF.


      Tried BIOS reset by removing the jumper and booting with USB drive, the NUC does not display the BIOS recover menu, it shows the same symptoms as above.


      Tried re-seating the RAM stick and booting without RAM stick, same issue as above.


      RAM used: Kingston 8 GB  PC3L - KVR16LS118

      SSD used: Samsung 850 EVO 120GB  (MZ-75E120B/AM)


      I tried submitting a RMA via Intel service request and it says Support is unavailable.


      P.S. I work for Intel, when I try to sign in with my corporate credentials, I get the following message:


      Single Sign-On Error

      We can't log you in. Check for an invalid assertion in the SAML Assertion Validator (available in Single Sign-On Settings) or check the login history for failed logins.



      Can anyone help me solve the issue or help me submit the RMA.



      Vikas J.