1 Reply Latest reply on Sep 12, 2016 3:04 PM by Intel Corporation

    NUC 5i5RYH power on problems


      I purchased a new NUC 5i5RYH that does not power on sometimes. It is very strange. There are times when it powers on and at other times it does not power on. The strangest part is that most of the time it powers on after I unplug the power pin at the NUC’s end and plug it back into the NUC. However, the adapter which came in the box eventually stopped working. I was really worried whether the unit died totally. I took it to a computer shop and the technician over there used a compatible adapter and it powered on to my surprise. Thinking that my problems had ended I purchased the adapter. However, to my dismay, the problem started repeating itself again with the new adapter. Only if I unplug the power chord from the NUC end and plug it back again, it works. As I have found this technique, the problem is manageable now. I have typed this query from the NUC itself. I have worked in many organisations and seen many PC’s. I have had PC’s of various kind at my home including Windows based PC’s,  Mac Mini, etc. Nowhere have I seen a problem like this where the PC powers on sometimes and sometimes it does not power on. I am really worried and clueless as to what needs to be done. The fact that when I unplug and plug again the power socket at the NUC end makes me think whether there is any loose mechanism inside the NUC. Though the problem can be solved by unplugging the power at the NUC end and plugging it back, I do not think that it is the ideal situation. I have no other problems with the NUC and really love it as it works lie a charm, if it powers on. I am using Windows 10 Home with the Anniversary Update and have updated all the bios and chipset drivers. Please advice.

        • 1. Re: NUC 5i5RYH power on problems
          Intel Corporation
          This message was posted by Intel Corporation on behalf of

          Hello Yadav_Hemmady:
          Correct, you are right, that is not the ideal situation and the NUC does not supposed to work like that, so, let me apologize for any inconvenience.
          Based on the fact that you already replaced the power adapter, that indicates that this problem could be related to the NUC itself, as you mentioned could be any loose mechanism inside the NUC or the power port itself.
          The NUC has 3 years of warranty and we can always replace it for you, if you are interested in the replacement, please get in contact directly with us through chat, email, phone or online support, you just need to select NUC on product type and you will get those options:
          Any questions, please let me know.