9 Replies Latest reply on Sep 26, 2016 2:31 PM by Intel Corporation

    Intel Edison stuck in reboot loop

    Uttee

      Hello all,

       

      I recently inherited an Intel Edison with Arduino breakout board. I connected to the serial console and see that Edison is repeatedly showing the message below(pasted at the end). To recover from this I have tried the following

      1) On a MAC installed Intel software and tried updating the firmware. The software doesn't detect the board

      2) On a Mac tried flashall.sh, but it looks like this script does not work on Mac. I didn't bother fixing the script, instead installed moved to my Ubuntu machine.

      3) On Ubuntu 15.0.4 installed intel software and tried updating the firmware. The software doesn't detect the board.

      4) On ubuntu I tried flashall.sh. I noticed that the USB ID the shell script is looking for was hardcoded to 8087:<something>, but my Edison ID was 8086:<something else>. I fixed the script but it still didn't work. Then I ran the command "watch lsusb" and noticed that the intel USB device is available for sometime and disappers and appears again, so on in a loop.

       

      Any pointers on how to recover from this? Thanks!

       

      ******************************

      PSH KERNEL VERSION: b0182727

                      WR: 20104000

      ******************************

       

      SCU IPC: 0x800000d0  0xfffce92c

       

      PSH miaHOB version: TNG.B0.VVBD.0000000c

       

      microkernel built 23:15:13 Apr 24 2014

       

      ******* PSH loader *******

      PCM page cache size = 192 KB

      Cache Constraint = 0 Pages

      Arming IPC driver ..

      Adding page store pool ..

      PagestoreAddr(IMR Start Address) = 0x04899000

      pageStoreSize(IMR Size)          = 0x00080000

       

      *** Ready to receive application ***