1 Reply Latest reply on Sep 7, 2016 1:39 PM by Intel Corporation

    UWP - SR300 - Can't reference SDK dlls

    SWAndy

      Hi there,

      I just downloaded and installed the complete SDK and tried the UWP Samples.
      But to no avail, since the solution first didn't find the dlls.
      Then I tried to reference them by myself via "Add reference" and "Browse". I tried this path: RSSDK\framework\UWP\ExtensionSDKs\Intel.RealSense\10.0.26.396\redist\CommonConfiguration\x86 (yes, build target was set to x86 to).

      None of the provided dlls in the x86 or x64 folder were added, because VS2015 yelled: "Could not be added. Please make sure that the file is accessible, and that it is a valid assembly or COM component."
      What could be wrong or what could I've done wrong?

      I also tried with v8 of the sdk, same error.
      I then tried the wpf samples... referenced the dlls(libpxcclr.cs.dll) according to the developer manual and they are working.
      But not the uwp as said. There's also no word about it in the manual(Intel® RealSense™ SDK 2016 R2 Documentation )

      I also posted here:UWP - Can't reference SDK dlls but haven't received any answer so far.
      Hoping my best in this place now.

       

       

      My Setup:
      Windows 10 10586.545
      VisualStudio 2015 update 2

      Best regards,
      Andy