4 Replies Latest reply on Sep 2, 2016 6:50 AM by blefish

    Intel HD 510 clocking issue

    blefish

      Hello

       

      I am an owner of an Intel motherboard notebook, notably the CPU is Pentium 4405U and GPU is Intel HD 510. When I started some games I noticed that sometimes they ran fine and at other times they were lagging a lot. I downloaded GPU-Z to verify the clock speeds and to my surprise the GPU clocks are not at 800MHz when the lagging occurs. The GPU load is 100% and the GPU clock speed is at 200MHz. My power profile is set to balanced but when this happens it did not make a difference whether it's power save or balanced.

       

      Is this a bug withing the Intel graphics drivers? I am using Windows 7, so I am not sure if this issue would be present with Windows 10.

       

      -EDIT-

      I noticed that when I replugged the AC on my laptop, the clock went up like normal but dropped back down in ~5 seconds. What could it be related to?

        • 1. Re: Intel HD 510 clocking issue
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello blefish:

          The problem with the games could be related to graphics drivers, on the link below you will find the latest version of the graphics driver for the Intel® HD Graphics 510 controller, please get into device manager, look for the option that says: “display adapters”, the look for “Intel Graphics”, right click on it, and select “Uninstall”, and then install this driver manually:

          Instructions to install the driver manually:

          http://www.intel.com/content/www/us/en/support/graphics-drivers/000005474.html

          Graphics driver latest version 4474:

          https://downloadcenter.intel.com/download/26099/Intel-Beta-Graphics-Driver-for-Windows-10-and-Windows-7-8-1-15-40-?product=88351

          If that driver does not work, then we will need to verify a few details:

          What is the specific model of the laptop?

          Did the games work fine before?

          Did you check the requirements of the game? Maybe it is too heavy for this processor.

          Did you restore the BIOS to defaults?

           

          Did you check with the manufacturer of the note book about this problem?


          In regard to the clock speed, we do have a tool to test the processor that does an overall test on it, including the clock speed, so if it passed the test it means that should be working fine.

          On the following link you will find the option to install it, please choose the second option o the left:

          https://downloadcenter.intel.com/download/19792/Intel-Processor-Diagnostic-Tool

          Another thing to try, if the driver above did not work, will be to use the Windows drivers.

          To do that, follow the instructions above to uninstall the current graphics driver, and then try a Windows update, a Microsoft driver should get installed, so you can test the game with that driver.

          Any questions, please let me know.

          Alberto

          • 2. Re: Intel HD 510 clocking issue
            blefish

            Thank you for the reply.

             

            I am already using the 4474 Beta drivers and they seem to work well, only that one issue. Initially I used the standard driver, which was soon replaced with Windows Update driver.

            After more debugging, it seems that when my laptop battery reaches 100% and I keep the charger plugged in, the GPU core clock does not go down anymore. The load is consistent 80-90% and GPU core clock at 800MHz (if I remember correctly). Could it be related to the battery not providing enough power? However the screen brightness doesn't go down, the CPU clock is also at 2GHz like normal so it would seem like only GPU is scaling down.

             

            I tried to use the diagnostic tool and it passed everything, on battery power and on charger too.

             

            If it's any help, my laptop has CLEVO/KAPOK OEM GPU.

            • 3. Re: Intel HD 510 clocking issue
              blefish

              After mode debugging it seems like it is indeed happening because the CLEVO vbios or related is scaling down GPU (and I noticed that CPU is affected, even though it didn't seem like so initially). It's probably done because the battery cannot provide enough power at these times, which seems OK in my book. However, I'm kind of dissapointed that I have to charge the battery to 100% and then I am able to play these games. I think it would make more sense if it disabled scaling when AC is plugged in.

              • 4. Re: Intel HD 510 clocking issue
                blefish

                Looks like I was able to solve my issue by using CLEVO control center (I have entertainment profile) and changing the power conservation value to "performance". This DOES NOT AFFECT Intel/Windows battery profile, this is something special for CLEVO laptops. When I had this set to "balanced" or "power saving" then on battery power the laptop slowed down a lot with games. I then switched it to "performance" and game FPS greatly increased, even though still on battery power.