1 Reply Latest reply on Aug 21, 2016 6:46 PM by Intel Corporation

    SR-IOV: dpdk16.07 on guest and ixgbe 3.19.1 on host - will that be a problem ? (requested invalid api version)

    Gopa

      I see the below message "requested invalid api version" on host ? Will that be an issue or is it benign ? Should I upgrade the host ixgbe to a later version ?

       

      On the host:

       

      [69576.199458] ixgbe 0000:88:00.1 p4p2: VF 2 requested invalid api version 3

       

      root# lsb_release -a

      No LSB modules are available.

      Distributor ID:    Ubuntu

      Description:    Ubuntu 14.04.4 LTS

      Release:    14.04

      Codename:    trusty

      root@mtpnjrsv113:~#

       

       

      root# ethtool -i p4p2
      driver: ixgbe
      version: 3.19.1
      firmware-version: 0x80000811, 1.1067.0
      bus-info: 0000:88:00.1
      supports-statistics: yes
      supports-test: yes
      supports-eeprom-access: yes
      supports-register-dump: yes
      supports-priv-flags: no

       

       

      On the guest:

       

      root# lsb_release -a

      No LSB modules are available.

      Distributor ID:    Ubuntu

      Description:    Ubuntu 14.04.2 LTS

      Release:    14.04

      Codename:    trusty

       

      root# find / -name rte_kni.ko

      /var/lib/dkms/dpdk/16.07/3.16.

      0-30-generic/x86_64/module/rte_kni.ko
      /lib/modules/3.16.0-30-generic/updates/dkms/rte_kni.ko