1 2 Previous Next 16 Replies Latest reply on Sep 2, 2016 7:45 AM by Intel Corporation

    Windows 10 intel ssd 540s superfetch on or off?

    AlexAlexandru

      Many people say on the internet for ssd superfetch should be off.What does intel say about Windows 10 superfetch on intel ssd?On or off?

        • 1. Re: Windows 10 intel ssd 540s superfetch on or off?
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello AlexAlexandru,

          Regarding your request, you should  disable the superfetch option for SSDs.
          In this link you will find more information about it, please refer to the part "What are the requirements for TRIM?"  Basically we do recommend disabling superfetch.

          Let us know if you require any more assistance.

          Regards,
          NC

          1 of 1 people found this helpful
          • 2. Re: Windows 10 intel ssd 540s superfetch on or off?
            Qwinn

            I'm actually pretty surprised by this answer.  If you look under System Tuner in Intel SSD Toolbox, it lists the setting "SuperFetch/Prefetch", Status "Feature is Optimized", and the Recommended action is "No action required - Intel recommends enabling SuperFetch for SSDs in Windows 8.".  Looking in service manager, the Superfetch service is running.

             

            Superfetch-toolbox.png

             

            And this is weird... I see on this page that the screenshot of the toolbox at this link is giving the opposite advice:

             

            Tuning Your Intel® Solid State Drive with the Intel® SSD Toolbox

             

            I am running Win10 Anniversary Update, for the record.

            • 3. Re: Windows 10 intel ssd 540s superfetch on or off?
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi AlexAlexandru,

              Actually the status "Feature is optimized" means superfetch and prefetch are disabled. If by any chance you see the service still running, we recommend to follow these steps:
               

              1. Hold the Windows Key, while pressing “R” to bring up the Run dialog box.
              2. Type “Regedit“, then press “Enter“.
              3. The Registry Editor window appears. Navigate to the following location in the Registry. 
                   
                • HKEY_LOCAL_MACHINE
                •  
                • SYSTEM
                •  
                • CurrentControlSet
                •  
                • Control
                •  
                • Session Manager
                •  
                • MemoryManagement
                •  
                • PrefetchParameters
              4. On the right side, double-click on “EnableSuperfetch“. If this value doesn’t exist, right-click the “PrefetchParameters” folder, then choose “New” > “DWORD Value“.
              5. Give “PrefetchParameters” one of the following values: 
                   
                • 0 – to disable Superfetch
                •  
                • 1 – to enable prefetching when program is launched
                •  
                • 2 – to enable boot prefetching
                •  
                • 3 – to enable prefectching of everything
              6. Select “OK“.
              7. Close the Registry Editor.
              Please let us know if it worked, about the screenshot, we will double check in our lab with a Windows® 10 system about the "recommended action" since we just checked on a Wndows* 7 and only shows: "No action required"

              Regards,
              NC
              • 4. Re: Windows 10 intel ssd 540s superfetch on or off?
                Qwinn

                "Actually the status "Feature is optimized" means superfetch and prefetch are disabled."

                 

                I suspected this might be the intent, but the reality appears to be different.  Everything I'm seeing says it's enabled.  And I am a bit confused by your directions.

                 

                "

                • On the right side, double-click on “EnableSuperfetch“. If this value doesn’t exist, right-click the “PrefetchParameters” folder, then choose “New” > “DWORD Value“.
                • Give “PrefetchParameters” one of the following values: 
                  • 0 – to disable Superfetch
                  • 1 – to enable prefetching when program is launched
                  • 2 – to enable boot prefetching
                  • 3 – to enable prefectching of everything

                "

                 

                My SuperFetch service is enabled and I don't have an existing registry key for either "PrefetchParameters" (that's the name of the folder, not a key, so not sure how I can give it a value, unless you mean create a "PrefetchParameters" key in a folder of the exact same name) or a key called "EnableSuperFetch" either.  What I do have is a key called "EnablePrefetcher", and that one is currently set to a value of 3.

                 

                Please note, this is a 4 day old clean install of Windows 10 Pro Anniversary Update.  I know I have not tweaked these settings, and the Intel Toolbox Tuner has called my settings "optimized" since I installed (and honestly it was the same prior to the AU, I don't think the AU changed anything in this regard).

                 

                So, if my System Tuner thinks the "Feature is optimized" means SuperFetch is disabled, it is incorrect, because everything I see says it's enabled and always has been.

                 

                At any rate, after clarification of what keys I'm actually supposed to have at the end of my editing, could you suggest which of the values 0-3 I should set the key to?  I always thought that SuperFetch and Prefetch are two different things and the recommendation may be different between the two.  If the recommendation is to disable Prefetch *and* SuperFetch, then I guess the value I would set the value to should be 0?

                • 5. Re: Windows 10 intel ssd 540s superfetch on or off?
                  pattex

                  I'm running the same version of Win10 (64 bit). It's not a fresh installation if that matters. Superfetch is enabled. The tuner insists on re enabling it if I disable it. There is only one drive, a 540s SSD running the latest firmware. The previous firmware exhibited the same behavior. The SSD is a cloned upgrade from a mechanical drive.

                   

                  I too am confused by the apparent inconsistent advice.

                  • 6. Re: Windows 10 intel ssd 540s superfetch on or off?
                    Qwinn

                    Oops, I forgot to mention, I'm using an Intel 750 1.2TB SSD, not the 540s, if it matters.

                    • 7. Re: Windows 10 intel ssd 540s superfetch on or off?
                      Intel Corporation
                      This message was posted on behalf of Intel Corporation

                      Pattex,

                       

                      Thanks for posting in our forum. It seems in your case the option is enabled due to the cloning you performed.

                       

                      Qwinn,

                       

                      Let's try a little different, could you and Pattex try the following:

                       

                      -Hold the Windows Key, while pressing “R” to bring up the Run dialog box.
                      -Type “services.msc“, then press “Enter“.
                      -The Services window displays. Find “Superfetch” in the list.
                      -Right-click “Superfetch“, then select “Properties“.

                       

                       

                      disable-superfetch.jpg

                       


                      As you can see, you can disable the service from there. Let us know if that worked fine.

                       

                      Regards,
                      NC

                      • 8. Re: Windows 10 intel ssd 540s superfetch on or off?
                        Qwinn

                        I disabled the SuperFetch service per your recommendation.

                         

                        This is the result:

                         

                        ToolBoxTuner.png

                        • 9. Re: Windows 10 intel ssd 540s superfetch on or off?
                          pattex

                          Same behavior for me. The tool wants to re-enable Superfetch.

                           

                          I've got a Samsung drive installed in a work laptop. Magician optimization has been applied. The Superfetch service is disabled.as a result.

                           

                          To reconcile inconsistent information, please advise what the services and registry settings should be. I assume Superfetch should be disabled. what about Prefetch?

                           

                          SSD Optimization Tips for Windows 10 You May Want to Know

                          • 10. Re: Windows 10 intel ssd 540s superfetch on or off?
                            database64128

                            On Windows 8 and higher versions, the Superfetch service is optimized for SSDs and is on by default when running on SSDs. Therefore you guys should re-enable it if you    had shut it down.

                            • 11. Re: Windows 10 intel ssd 540s superfetch on or off?
                              database64128

                              The reply dialog doesn't run properly on Safari on iOS.

                              • 12. Re: Windows 10 intel ssd 540s superfetch on or off?
                                AlexAlexandru

                                Untitled.png

                                Hello.Why does it says "Feature is not optimize" when I have set DIMP.If I press Tune it is set to HIPM,Isn't DIPM better than HIPM?

                                • 13. Re: Windows 10 intel ssd 540s superfetch on or off?
                                  Intel Corporation
                                  This message was posted on behalf of Intel Corporation

                                  Hello AlexAlexandru,

                                  We would like to verify all this information you and Pattex have provided to us, specially because we have compared the one we have here and it does not show the same behavior.
                                  We will keep you posted as soon as we have any solution for it.

                                  Regards,
                                  NC

                                  • 14. Re: Windows 10 intel ssd 540s superfetch on or off?
                                    Qwinn

                                    Er, just checking, is the behavior I'm showing also different from what you're looking at?  Or is the Intel 750 different somehow?

                                    1 2 Previous Next