3 Replies Latest reply on Aug 19, 2016 10:50 AM by dany_at_intel

    Unable to connect to hub when using multiple NICs

    Mr.Harmony

      I have an Unite standalone hub connected to a WiFi network.  I can successfully connect to the Hub, but only when my PC is connected to the WiFi network only.  If the PC has a wired connection AND a wifi connection it is unable to find the hub. 

        • 1. Re: Unable to connect to hub when using multiple NICs
          dany_at_intel

          Hi,

          The Intel Unite standalone hub needs to be on the same subnet as the clients. After verifying this, if the client is still not connecting, please make sure you don’t have firewall restrictions turned on for the Unite app.

           

          Let me know if you are still having issues after verifying this.

          • 2. Re: Unable to connect to hub when using multiple NICs
            Mr.Harmony

            Hi Dany,

             

            I've done some protocol traces and found that it appears the Unite client sends a UDP broadcast in order to find the Hub.  When a client is multihomed (i.e. connected to two networks such as corporate wired + wifi connected Unite hub) the broadcast does not emit on both interfaces.  This apparently is due to Windows TCP behavior.  If the Unite hub-connected network adapter is not first in the binding order, the UDP broadcast never reaches the Hub machine and thus it never responds to make a connection.  In this configuration I *am* able to connect to the Hub via HTTP to download the client  software so I have confirmed that I have connectivity and it's on the same subnet.

             

            Is there any way to explicitly force the Unite client to connect to a hub at a specific IP address (essentially skipping the UDP broadcast phase) - ?

            • 3. Re: Unable to connect to hub when using multiple NICs
              dany_at_intel

              Mr.Harmony,

               

              Standalone is meant for single business networks unfortunately there is no way to force the connection to an IP specified, which is different from enterprise mode.

               

              Please let me know if you have any other doubt