3 Replies Latest reply on Aug 22, 2016 11:23 AM by Intel Corporation

    "black screen" on Resume (on Lenovo Helix 2, Core M 5Y71) likely HD 5300 driver problem

    Nomendos

      There is problem "black screen" on Resume (on Lenovo Helix 2, Core M 5Y71) likely HD 5300 driver problem.

      Last driver, from Lenovo (same from Windows update build 1607) is v20.19.15.4444 (dated 13-06-2016) gives black screen very often as well as all other drivers before except only driver that ever worked well with sleep/RESUME without black screen was 2015/09/01 win64 v15.40.7.4279 (which is 1st Win10 driver for HD 5300 Core M, which kind of makes sense as 1st product validation is most strict and later Intel patches bugs for other parts maybe not testing same way previously released parts!?). However this driver can not be used anymore! Initially, last year there was way to disable driver updating in Win10 and it worked for a while, up until ~July when Microsoft started ignoring it and since then they force update driver with regular windows update despite user's setting/wish. Further insult is that user can not anymore install old and so far only working driver "v15.40.7.4279", because Win10 TH2/build1607 now requires signed drivers and even if driver signing would be disabled (not recommended) further problem is that on Lenovo you can not install Intel drivers anymore (which I was before, not sure when that stopped).

      Lenovo does not offer driver history download, so user can not find anymore place to download old Lenovo driver equivalent for v15.40.7.4279, since the only driver that can be downloaded today for Helix 2 for Intel HD 5300 is 20.19.15.4444 (and when new one gets released, this one will disappear from option to download).

      This situation is big pain to all Helix 2 owners.

      Note: I have Helix 2nd, Core M 5Y71, 8GB RAM, 256 GB Intel SSD (... and I've seen these machines being sold for "dumping prices" ~$300 most likely due to this problem that is ignored and not fixed for so long!?). I did not fully characterized behavior of this bug/problem but as I see there could be more details to its behavior, so I'll let Intel do that (as I am hearing that Broadwell never was fully made and validated for Win10!?)

       

      Intel, please fix this:

      1. making new HD 5300 driver update with proper fix

      or 2. either signing v15.40.7.4279 and telling us how can we install this version on Lenovo Helix 2nd

      or 3. helping us how we can download Lenovo HD 5300 driver v15.40.7.4279 (and install it on Win10-build1607 despite signing requirement or it is signed?)

      or anyone else have suggestion (but please only serious and well tested suggestions)