7 Replies Latest reply on Aug 22, 2016 11:30 AM by Intel Corporation

    USB Ports Not Working

    HGColeman

      I bought a NUC Kit NUC6i5SYK online at Amazon and put it together,installing Win 7 with free upgrade to Win 10.  From the beginning, one rear USB port did not function.  I plugged my keyboard into the other rear port, my mouse into a front port and a 4-port USB hub into the other front port.  Good so far, except for the other rear port not functioning no matter what device I plug into it.  Today, though not sure if it is related, I loaded software for a DLink Rangebooster USB adapter and tried plugging it into the bad USB port.  Didn't work, then plugged it into one of the 4 ports on the hub and it worked.  However, now the other rear USB port where the keyboard was plugged in does not work!  Had to plug the keyboard into the 4-port hub.  How do I get the now 2 not working rear USB ports to work?  I'm starting to panic with only 5 ports and more devices than that to possibly plug in at one time.  Of course, I can unplug a DVD drive I'm not using and plug in a USB hard drive, for example, but I wold like all 4 USB's on the NUC to work.