2 Replies Latest reply on Mar 20, 2010 12:22 PM by Bergy

    How to get 5100 AGN to connect at N speed?

    mco

      Need some help to figure this out.  Just got a new Lenovo x301 running Windows 7 Professional 64 bit.  The wireless adapter is the PC is Intel(r) wifi link 5100 agn.  So far only one problem - it won't connect at faster than 54Mbps to my wireless router (DLink DIR-655). I have 2 other computers which both are connecting at wireless-N speeds between 130 and 270Mbps depending on their mood (or wireless adapter) so I am reasonably confident the router, settings (e.g., WPA2 encryption, 20/40 Auto channel width) are generally fine.    Despite this - the x301 gets stuck at 54Mbps.  When I look at output of the adapter diagnostics for x301 it claims that my network/access point is of "unknown type".  When I look on the router status page it says the PC is connected as wireless G.  When I look at Access Connections software from Lenovo it say the network is of type wireless N.  In all cases though 54Mbps is reported as the connection speed.  I have latest driver from Intel site and mirrored settings form support page (with exception of router at Wireless N only - wouldn't work with other devices I have - e.g., Blackberry) I have also tried about everything I can think of and seen on various fora, e.g., mirror adapter settings people claim work, download and update driver from Intel site, but can't make a difference.  Stuck at 54Mbps.

       

      Any ideas regarding what I am missing would be appreciated.

       

      Thanks.

        • 1. Re: How to get 5100 AGN to connect at N speed?
          mco

          Finally got this figured out.   In case others have the same problem as I did (i.e., PC wouldn't connect at more than 54Mbps/wireless-G speeds) and want to avoid hours of frustration and deadends...  To summarize what I did to get this to work

           

          1.  Have current Intel driver (on their website); Lenovo had not installed current driver on my new laptop; oh well
          2.  Set router to 20/40 Auto channel width, mixed n/g
          3.  Turn on WPA2/AES encryption
          4.  Enable WMM and QoS on router (QoS was already on for me, but people on Intel forum told me to check it was on so sure it must do something good)

           

          Step 4 worked magic - went from 54Mbps to 270Mbps in a hurry.  Speed fluctuates a bit it seems but still a vast improvement.

          • 2. Re: How to get 5100 AGN to connect at N speed?
            Bergy

            This certainly worked for me the WPA2 setting seemed to be the clincher.  Getting TX 150 Mps and RX 300 at 92% signal strength.  I noticed that these figures drop off rapidly if the signal strength goes down even to 80%  180RX at 70%, so this shows how important a good signal is for the higher levels.

            Not sure why its only transmitting at 150Mps, but that's hardly a problem for Internet access, especially where I live with only 2Mbs at best.  As with setting up the wireless in the first place, it only takes one setting out of place and it just won't work.  I am using SMC7904WBRA-N UK  modem/router and you have to remember to delete the profile in the wireless setup and then reinstall it again.  I found the easiest way was to just do the push button thing in the wi-fi protect set-up section in the wireless application, then push the button on the modem/router and wait for the wireless to pick up the modem/router.  You need to have the ethernet cable setup too, cos once you save the settings in the modem/router, it loses the internet connection to the modem.  Once I had all the settings right then I disabled the ethernet connection, unplugged it and put the modem back downstairs, thereby eliminating the need for the extension cable to the phone line.

            When setting these things up, it pays to be patient, especially for a first time.  I kept my old USB modem connected up and just disabled it through Internet Explorer, Tools, Internet Options, Connections, clicking on Never Dial A Connection, when experimenting/setting up the Wireless LAN.  Just have to switch it back on again if you needed to access the Internet through the old modem.