5 Replies Latest reply on Sep 1, 2016 11:23 PM by Intel Corporation

    ixgbe can not work in IntMode=2(MSI-X)

    taira

      Hi! all

       

      I use 82599EN with 10Gbps SFP module. I measre through put and the result is 1.3Gbps.

      I would like to improve through put, so I would like to use MSI-X.

       

      I enter "insmod ixgbe.ko IntMode=2". The result is below,

      This driver fail to start because  of "Failed to allocate MSI-X interrupts. Err: -28".

      -----

      ~# insmod ixgbe.ko  IntMode=2

      Intel(R) 10 Gigabit PCI Express Network Driver - version 4.3.15

      Copyright (c) 1999-2015 Intel Corporation.

      ixgbe: Interrupt Mode set to 2

      ixgbe 0000:01:00.0: Failed to allocate MSI-X interrupts. Err: -28

      ixgbe 0000:01:00.0: Disabling VMQd support

      ixgbe 0000:01:00.0: Disabling RSS support

      ixgbe 0000:01:00.0: PCI Express bandwidth of 16GT/s available

      ixgbe 0000:01:00.0: (Speed:5.0GT/s, Width: x4, Encoding Loss:20%)

      ixgbe 0000:01:00.0 eth2: MAC: 2, PHY: 15, SFP+: 5, PBA No: FFFFFF-0FF

      ixgbe 0000:01:00.0: 00:a0:c9:12:34:56

      ixgbe 0000:01:00.0 eth2: Enabled Features: RxQ: 1 TxQ: 1

      ixgbe 0000:01:00.0 eth2: Intel(R) 10 Gigabit Network Connection

      platform leds.7: Driver leds-gpio requests probe deferral

      -----

      Could you tell the reason which occurs "Failed to allocate MSI-X interrupts. Err: -28" ?

       

      BR,

      Taira

        • 1. Re: ixgbe can not work in IntMode=2(MSI-X)
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi Taira,

           Thank you for the post. I will check on this, can you also provide below info:
          1) what is the brand and model of the fiber optical module use? 
          2) Is this an onboard NIC 82599EN ? What is the brand and model of your system? 
          3) Did you install the VF Linux driver 
           https://downloadcenter.intel.com/download/18700/Network-Adapter-Virtual-Function-Driver-for-10-Gigabit-Network-Connections?product=69658
          4) Try run the command 'lspci -v' to show  device with MSI or MSI-X capabilities 

          5) Try run lspci -t' gives the list of bridges. Please  check 
          /sys/bus/pci/devices/*/msi_bus will to find out  whether MSIs are enabled  or disabled

          Thanks,
          wb
           

          • 2. Re: ixgbe can not work in IntMode=2(MSI-X)
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Hi Taira,

               Please feel free to provide information requested on my post.

            thanks
            wb
             

            • 3. Re: ixgbe can not work in IntMode=2(MSI-X)
              taira

              Hi!  wb

               

               

              Sorry for my late reply. I answer your quesstions.

               

               

              1) what is the brand and model of the fiber optical module use?

               

              The SFP module which I use  is FINISAR FTLX8573D3BTL.

               

               

              2) Is this an onboard NIC 82599EN ? What is the brand and model of your system?

               

              Yes. 82599EN is implemented on our original board. The board is not commercial.

               

               

              3) Did you install the VF Linux driver

              https://downloadcenter.intel.com/download/18700/Network-Adapter-Virtual-Function-Driver-for-10-Gigabit-Network-Connections?product=69658

               

              No,I use ixgbe driver, not ixgbevf driver.

               

               

              4) Try run the command 'lspci -v' to show  device with MSI or MSI-X capabilities

               

              I attached  the result.

              ------[begin]------

              00:00.0 PCI bridge: Altera Corporation Device e000 (rev 01) (prog-if 00 [Normal decode])
              Flags: bus master, fast devsel, latency 0
              Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
              I/O behind bridge: 00000000-00000fff
              Memory behind bridge: c0000000-c00fffff
              Prefetchable memory behind bridge: 00000000-000fffff
              Capabilities: [50] MSI: Enable- Count=1/4 Maskable- 64bit+
              Capabilities: [68] MSI-X: Enable- Count=64 Masked-
              Capabilities: [78] Power Management version 3
              Capabilities: [80] Express Root Port (Slot-), MSI 00
              Capabilities: [100] Virtual Channel
              Capabilities: [200] Vendor Specific Information: ID=1172 Rev=0 Len=044 <?>

              01:00.0 Ethernet controller: Intel Corporation Device 1557 (rev 01)
              Flags: bus master, fast devsel, latency 0, IRQ 265
              Memory at c0000000 (64-bit, non-prefetchable) [size=128K]
              I/O ports at <unassigned> [disabled]
              Memory at c0020000 (64-bit, non-prefetchable) [size=16K]
              Capabilities: [40] Power Management version 3
              Capabilities: [50] MSI: Enable+ Count=1/1 Maskable+ 64bit+
              Capabilities: [70] MSI-X: Enable- Count=64 Masked-
              Capabilities: [a0] Express Endpoint, MSI 00
              Capabilities: [e0] Vital Product Data
              Capabilities: [100] Advanced Error Reporting
              Capabilities: [140] Device Serial Number 00-00-00-ff-ff-00-00-00
              Capabilities: [150] Alternative Routing-ID Interpretation (ARI)
              Capabilities: [160] Single Root I/O Virtualization (SR-IOV)
              Kernel driver in use: ixgbe

              ------[end]------

               

               

               

              5) Try run lspci -t' gives the list of bridges. Please  check

              /sys/bus/pci/devices/*/msi_bus will to find out  whether MSIs are enabled  or disabled

               

               

              lspci -t result:

              -[0000:00]---00.0-[01]----00.0

               

              cd /sys/bus/pci/devices

              I find 2 directories, 0000:00:00.0 and 0000:01:00.0.

              In 0000:00:00.0, 1 is written in msi_bus.

              In 0000:01:00.0, msi_bus is empty.

               

               

              BR,

              Taira

              • 4. Re: ixgbe can not work in IntMode=2(MSI-X)
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hi Taira,

                 

                Thank you for the reply, I will check on this and update if there is any finding.

                 


                rgds,
                wb

                • 5. Re: ixgbe can not work in IntMode=2(MSI-X)
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hi Taira,

                    What is the exact ixgbe version used and please try out latest latest version in sourceforge  https://sourceforge.net/projects/e1000/files/?source=navbar 

                      Please feel free to update me.

                  rgds,
                  wb