4 Replies Latest reply on Aug 9, 2016 12:21 PM by Intel Corporation

    Intel AC 7260 does not show 802.11n mode preference

    zaiac

      Hi,

       

      I've recently bought dual band router TP-Link archer C7 and was hoping to get better WiFi performance by using 5GHz (plenty 2.4 GHz WiFi's in the neighborhood).

      I've set up the router, upgraded firmware to the latest one.

       

      On my laptop I have an Intel AC7260 card with latest driver (18.33.3.2) - upgraded today:

      Driver.png

       

      I was looking at Intel www to see the recommended card settings (Advanced Intel® Wireless Adapter Settings ) and found the "802.11n mode" which is not visible:

       

      advanced settings.png

       

      My WiFi connection is still poor (max 10 Mbps while on a cable it goes way over 30).

      Can anyone help me how can I turn "n" (or possibly "ac" - which is supperted by the router for 5GHz WiFi) on the Intel card?

       

      Thanks a lot!