2 Replies Latest reply on Aug 1, 2016 1:47 PM by Intel Corporation

    Intel DZ87KLT-75K irritating issue

    Netxzero

      Before anything else, this is my rig.

       

      4770k

      kingston hyperx predator 2400mhz - stock speed under xmp 1.3 (4x4gb)

      cm 750w psu

      gtx 980ti

      windows 10 home x64

       

      Hi,

       

      I have gotten this board with a sale 2 weeks ago. everything seems to be working fine. updated the bios to 0457 with the 4770k and boots just fine.

       

      But then with this bios, everything that I save as a setting gets saved other than processor speed in which i tried setting it to 4.2ghz then it goes back to 3.9ghz in the bios as well as in windows. plus whenever I tried to set my memory stock speed to 2400mhz, it does not boot. it goes from post then off then post then off, same issue that I have read with the bios memory issue since the board came out.

       

      its irritating as hell believe me, wasted 3 days of my time off leave for nothing.

       

      I tried downgrading to 0453 because i cant get anywhere with the irritating "most updated bios" then things started to work. everything goes well and i was able to overclock to 4.2ghz without a problem so what am i saying as numerous issue?

       

      i tried setting the ram to its stock speed of 2400mhz and boots just fine and i was able to use my PC but whenever i tried to download something like ANY SOFTWARE, it says network problem then i went ahead and check if anything was a miss from the device manager so i checked on the drivers then everything looks good. i tried updating some games that are NOT on steam because they had default launchers like heroes of the storm from blizzard and world of warships from war games and the same problem happens wherein it does not want to update the file because it keeps on saying that there is a failure in extracting the package. so my mind was blown and I cannot seem to know where the problem is. i reformatted like 5-6 times and was up for more than 36 hours just trying to fix this board.

       

      finally when i was about to give up, I tried lowering it to 2133mhz with manual timings which is also based on the XMP profile and everything went fine including downloading software and updating games.

       

      So my question is:

       

      1. why does the 0457 does not work on the board?

      2, bios 0453 is the only bios i can go to and seems to me that all this madness is pointing towards the bios support for the memory?

      3. me and my friend bought the same board but his was able to update to 0457 and was even able to use a gskill trident memory to go as high as 3000. bios faulty again?

      4. i tried re-updating to 0457 and its much much worse than before as my mouse does not even work anymore with it. luckily flashing back to 0453 only needs a keyboard. a faulty board or again, bios?

      5. It should support 2400mhz according to the website as i saw somewhere but then why this does not work?

      6. how to solve this issue?

       

      Thank you for the help in advance. hopefully somebody can shed some light.

        • 1. Re: Intel DZ87KLT-75K irritating issue
          N.Scott.Pearson

          First of all, let me start by saying that Intel warrants support for speeds up to 1600MHz. While every possible effort was put into supporting XMP profiles and speeds above this level, there still could be issues with particular DIMMs.

           

          Let me address your questions in order...

           

          1. I have use this BIOS release on my board since its creation and I have never seen any issues with settings not being saved. That said, I am not an overclocker and I use and configure memory intended for 1600MHz operation only. Note also that, if the BIOS cannot successfully initialize the processor and memory according to the settings that are specified (and saved), it will (at least in the latter case) lower them to levels that will work.
          2. Well, since the memory controllers are in the processor, I would say that the issue has something to do with it - but it could also be the memory or the board (or, more likely, a combination). Some processors are more overclockable that others - and yes, using memory faster than 1600MHz *is* considered overclocking (well, some parts of) the processor.
          3. No, he just has better processor and/or (at least more compatible) memory.
          4. Yes, it could be the fault of the board. For example, noise on, or interference with, the memory busses can cause many issues and limit clock speeds.
          5. There is a big difference between "can" or "should" and "will". While the supported-memory page says 2400MHz is supported, you will note that none of the listed memory goes beyond 1600MHz. As well, as I have said, it depends upon the particular processor, the particular board, the particular memory, etc.
          6. There are two things you could try: (1) Unplug system from A/C power and remove CR2032 battery from board for 15 minutes (this drains CMOS completely) and (2) Reinstall the 0457 BIOS using the Recovery method (this ensures that all components in the flash are fully updated; see instructions here: Intel Desktop Boards Recovery BIOS Update Instructions).

           

          Hope this helps,

          ...S

          • 2. Re: Intel DZ87KLT-75K irritating issue
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            I find very helpful Scott's comment about memory, processor and BIOS support for your Intel(R) Desktop Board  DZ87KLT-75K.

            Allan.