2 Replies Latest reply on Aug 10, 2016 4:05 AM by Intel Corporation

    I210 lost firmware

    N0T3P4D

      Hi,

       

      my Supermicro X10SRL-F has two onboard I210 NICs. Two days ago, after having it passed one through to a PFSense VM with KVM, they now show up under Linux as

       

      07:00.0 Ethernet controller: Intel Corporation Device 1531 (rev 03)

      08:00.0 Ethernet controller: Intel Corporation I210 Gigabit Network  Connection (rev 03)

       

      Only the second one is detected, the first one is missing in the BIOS, too. I've had the problem before and solved it by re-flashing the firmware which was provided by Supermicro support. I'm not certain about the circumstances back then, but it's possible that it was related to pass-through, too. However, it does not seem to be easily reproducible as the same setting has worked flawlessly several times before. Before trying to re-flash the firmware as advised by Supermicro, I'd like to ask if

       

      - this is a known problem (I couldn't really find related reports) and if yes how it can be avoided

      - you could use a firmware dump to get an idea of the problem / cause

       

      Of course, any other helpful information is appreciated! The NIC was running with firmware Rev 1.24 (05/21/2013), they've sent me Rev. 1.27A (8/27/2015) to test.

       

      With regards

      N0T3P4D