6 Replies Latest reply on Aug 18, 2016 8:13 AM by FerryT

    Turn off DMA for the HSU (uart)

    FerryT

      Does anybody know how to disable DMA of the high speed uart, going through the kernel code, I get the impression that using DMA is an option of the driver that is enabled by default.

       

      The DMA is causing 2 problems for me:

      • after receiving data a 2ms delay that almost defeats the purpose of using a high baud rate
      • as I understand (correct me if I'm wrong) using DMA parity/framing errors are not converted to NULL char's (as the DMA hardware does not know about errors), so communication errors can go undetected (at the byte level).