4 Replies Latest reply on Sep 10, 2016 1:00 PM by Intel Corporation

    NUC6i3SYH SA...503 won't boot, SA...502 will




      I have a number of Intel NUC6i3SYH, some SA H87086-502, and some SA H87086-503.


      All are running the same BIOS with the same settings (flashed from the same .bio file): "SYSKLi35.86A.0045.2016.0527.1055".


      I have the same RAM and the same SSD.


      The 502 model boots properly.


      The 503 model (with the same physical harddrive and ram) shows the BIOS splash screen and does not boot from the harddrive.


      Boot priorities are identical. I have tried UEFI, and no UEFI.


      I have tried four different 503 models and they suffer the same problem, while three different 502 models do not suffer this problem.


      There are no errors, error codes, or screens other than the UEFI or regular bios message informing me that there is no suitable boot device (or the network boot option looping if that's enabled).


      Both revisions boot from USB just fine, and successfully complete installing the a disk image using clonezilla (syslinux).


      The OS in question is Ubuntu Linux 14.04, and I have tried the default kernel and the latest kernel, although the NUC doesn't appear to even get to the kernel so I doubt the OS is relevant at all.


      Additional information:

      I have tried two models of harddrive: Kingston SSDNow300 120GB, and a 120GB samsung drive, and observed no change in behavior.

      I have tried two different models of RAM chip: Crucial PC4-2133P-SAB-10, and G-Skill Ripjaws F4-2133C15S-8GRS (both are 1.2V CL15 DDR4-2133 SODIMMs), again with no change in behavior.



      I have also tried an M.2 drive: A-Data SP900 M.2 128GB M.2-2280 Solid State Drive without success.


      Edit #2:

      I have tried not installing the latest BIOS, and using the one that the 503 series comes with "SYSKLi35.86A.0042.2016.0409.1246", without success.


      Edit #3:

      I have tried an MBR based partition rather than a GPT and reinstalling GRUB resolved the issue. Same partitions, just a different partition format. I am still very interested in knowing how a hardware revision would break boot compatibility like this.


      Message was edited by: Joseph Duchesne