9 Replies Latest reply on Dec 2, 2016 8:05 PM by mahsah

    Linux suspend issue Solved!

    cvare

      Hi all, we've released our last BIOS (4th generation NUC) that fixes the NUCs with the Linux suspend issue.  I know this has been a long time coming, and your patience is greatly appreciated!!

       

      Here's quick links in case you haven't updated yet.

       

      4th generation, D54250WYK/D34010WYK: Download BIOS Update [WYLPT10H.86A]

      5th generation, NUC5i5MYHE/B: Download BIOS Update [MYBDWi5v.86A]

      5th generation, NUC5i3MYHE/B: Download BIOS Update [MYBDWi30.86A]

      5th generation, NUC5i[X]RYK/H: Download BIOS Update

        • 1. Re: Linux suspend issue Solved!
          Intel Corporation
          This message was posted by Intel Corporation on behalf of

          Great information, let's try to update the BIOS to correct this issue. 

          Allan. 

          • 2. Re: Linux suspend issue Solved!
            bobdodger

            Since the suspend issue has been here on so many NUC models, on so many NUC users, for so many years, you want to share some more details about the real cause for this issue? e.g. the cause for 'power button wake failure', the cause for 'bricked NUC after unplug power', etc. I think NUC users deserve a more detailed answer, like your 'FAQ for WHEA UNCORRECTABLE ERROR'.

             

            Also on the release note of 4th gen WY NUC (BIOS 0042), WYLPT10H.86A.0042.2016.0704.1441,

             

            - "Updated Visual BIOS to version 2.2.17. Fixes include:…"

            It should be 2.2.20, right?

             

            - "Fixed an issue where the NUC can't wake up from S3 by pressing the power button in Linux."

            How good/real is this fix, compare to the same fix on BIOS 0038? ('Fixed issue where system with Linux Ubuntu* cannot resume from sleep.')

             

            - "Fixed issue where the CIR remote controller would still power on the NUC when CIR was disabled."

            How good/real is this fix, compare to the same fix on BIOS 0035? ('Fixed issue where CIR remote still wakes the NUC when CIR is disabled in BIOS.')

             

            I want SERIOUS answers!

            • 3. Re: Linux suspend issue Solved!
              cvare

              Whoops, sorry about that, yes 2.2.20.  It has been fixed.

               

              I'm checking with the BIOS engineers on the rest of your questions, but after looking at the previous BIOS notes, it looks as if that is a mistake, and should only be there once.

              • 4. Re: Linux suspend issue Solved!
                cvare

                Here's what I found.

                 

                The fix in BIOS 0038 was for S3, the fix in BIOS 0042 is for S4.

                 

                The initial fix for the Logitech remote didn't work, so they had to fix it again in BIOS 0042.

                • 5. Re: Linux suspend issue Solved!
                  Apachez

                  Finally!

                   

                  Care to elaborate a bit further what the fix actually is since its really odd that removing the retardedly positioned bios battery was the only way to restore the NUC (removing external power wasnt enough which is really odd in order to reset a cpu)?

                  • 6. Re: Linux suspend issue Solved!
                    opa1

                    The date for the new BIOS on the page Download BIOS Update [WYLPT10H.86A]  is incorrect - it shows July last year...

                    • 7. Re: Linux suspend issue Solved!
                      mahsah

                      @intel

                      How confident are you about this fix? It was S3 which was fixed version 0038.  Now it is S4 fix in 0042?  I see 0043 is out. Not sure if i should update. So far I have been hit 3 times with this problem.  And this is 3rd year after purchase. The warranty will soon be not valid. After every replacement i have updated to latest BIOS available.  Now I am on version 0042. However I am scared to enable suspend in my linux mint now.  How many more bugs are there S5 suspend, S6 suspend ... .  I regret that I bought this product.

                      • 8. Re: Linux suspend issue Solved!
                        cvare

                        Sorry Apachez, I didn't see your reply until now.  I'm checking with the BIOS engineers.

                         

                        @Mahsah, very confident.

                         

                        I completely understand your frustration, it was VERY frustrating and took a long time to fix.  However, 3 times in 3 years is incredibly small.  EVERY computer has issues, big and small, and while this was an annoyance, it seems to me that it's on the smaller side.  I do hope you continue to give us feedback so we can improve our products and possibly consider the NUC again.  We do appreciate your patronage.

                        • 9. Re: Linux suspend issue Solved!
                          mahsah

                          cvare,

                          Thanks for your response. I have D54250WYKH.  I do not agree to you comment about the incidence frequency. The first 2 times where within 2 months and then I had kept suspend disabled for most of the time. I enabled only after I updated to version 0038, and it was dead again in few weeks. I am an end customer and not someone who build hundreds of NUCs and computers for others. This is a case of single customer's NUC failing 3 times.  I am sure that this was easily reproducible in your test environment. Every time this happened I had to take it back to shop from where purchased, they will then send to Intel and it would take at least a week to get the replacement.

                          I can understand that every product can have issues, however the fact that it took so long that means it was not on intel's priority. I am sure if this was happening for Windows intel would have fixed this in a week's time.