4 Replies Latest reply on Jul 27, 2016 1:38 PM by Intel Corporation

    Restore broken Edison

    vmik

      Hello everyone!

       

      Recently bought a used Intel Edison Board for Arduino.

      The seller said that the kit is functioning properly. He before the sale download some sketch for test and everything was ok.

      But when I got it, it looks like it's not working properly.

      First of all, if I connect microUSB port (which is in the middle) to host PC (SW1 switch is turned to microUSB) lights the DS1 and DS2 LEDs and stays on,

      but nothing more happens. No any USB drive or other device is appear in host PC (Windows).

      I also tried to connect it to Ubuntu host and check dmesg output when connect it. Complete silence. No any message in the output.

      Then I tried to connect secondary microUSB port (close to the corner) which is serial console, new COM port appeared in the system.

      But if I connect Putty to this port, there is also silence. No any character received.

      At the same time the Intel Edison unit heats up.

      And the power button seems to work. If I press it for about 5 or bit more seconds, the module is switched off. Then if I press it for about 2 seconds, it switched on.

       

      So, seems the edison module does not start. No any communication via USB ports.

      How could I check is it software problem (bootloader or somthing else) or some part of hardware is broken?

       

      This is my last hope to make it work.