3 Replies Latest reply on Aug 8, 2016 11:56 AM by Intel Corporation

    WARNING Enabling hard disk password (ATA Password) on Intel 540S SSD causes complete data loss

    Invalid_username

      Hi All,

       

      I've been asking in the thread here SSD 540s firmware update failure for a while for the latest firmware update FUT 2.1.3 - since as per the vulnerability report here Intel® Product Security Center, there is a report of issues with the ATA password function and this model of SSD (Intel 540s).

       

      As we need passwords on our hard disks here, I went ahead regardless and tried to enable the ATA password on a new Lenovo T460S with the 1TB Intel 540s M.2 SSD installed.

       

      After setting the password in BIOS, on reboot the intel SSD prompted for the password - which it accepted, but the data partition was completely corrupted and gone!,

       

      I was able to boot from a USB and restore the system from backup, and it restored fine with the ATA password intact and working - but I don't trust that it won't just corrupt randomly ...

       

      On the vulnerability report here Intel® Product Security Center , it says , Quote "Intel has not received any reports of any Intel SSD products having experienced this issue."

       

      Well I think Intel should edit that report now, because I have an SSD here and it's 100% experiencing this issue. So now you HAVE recieved reports of this issue. I'm under pressure to roll out 15 laptops with this configuration but can't move ahead until Intel rolls out the firmware update....

       

      It's pretty poor that the vulnerability was acknowledged on the 13th June 2016 and the article says "Intel strongly recommends that customers with the listed products download and apply the mitigated firmware version using the update source outlined above." ... and yet they are STILL not providing a mitigated firmware version!??

       

      nestor_intelintel_corpSolid State Drives