4 Replies Latest reply on Jul 15, 2016 12:10 PM by TicoJohn

    NUC5i5ryh USB headset issues

    TicoJohn

      I have been very pleased with the NUC5i5RYH running Linux (Lubuntu 15.10 and Debian Stretch), until today. I decided to install Skype on the Lubuntu distribution and the install went well. However, I could not get the NUC to recognize my USB headset. I had the headset connected via a 2 meter extension cable, which works well on my regular desktop. The "blue" indicator LED on the headset would not even illuminate. I tried every USB port on the NUC with the same results. So, I removed the extension cable and plugged directly to the NUC and the indicator illuminated, so I thought AH HAH; we're all set. But then came the next problem. While I could get the sound output to play through the headset the audio input was HORRIBLE. Again, this same headset (Genius) works great on my other PC (running 32 bit Wheezy). I also tried just recording sounds (not using Skype) and get the same results on the NUC. The audio input is garbled. I don't know if this is a problem with the USB system on the NUC or if it is the Lubuntu installation. I have not yet tried the headset on the Debian install.  Just wondered if there were any others having similar issues and what they may have done to correct the problems.  

       

      One other thing I just thought of. On my regular desktop, the volume control on the headset pops up a volume control icon when I adjust the volume. This does not happen when connected to the NUC. Perhaps it is a driver issue. I will report back after trying the headset on Debian Stretch.

        • 1. Re: NUC5i5ryh USB headset issues
          TicoJohn

          Wanted to update this. Having same problem on Debian Stretch. So it is either a Linux/NUC compatibility issue or the NUC can't handle a USB headset.

          • 2. Re: NUC5i5ryh USB headset issues
            TicoJohn

            Okay, I have partial success. I have an old 4 port USB 2.0 hub (Genesys Logic) that I plugged int one of the rear USB ports. I now have good audio input and output. However, I still can not use the USB extension cable. The cable was purchased within the last two weeks and is supposedly a shielded high quality cable. Perhaps it has too high of impedance. At least I may be on the right path.  Will post again if I have a solution.  Any comments and/or suggestions are welcome.

            • 3. Re: NUC5i5ryh USB headset issues
              Intel Corporation
              This message was posted by Intel Corporation on behalf of

              Hello, TicoJohn:

               

              It is possible that issue here is related to the NUC not being compatible with these operating systems. I have tested an USB headset on the same unit you have running Windows® 10, but everything worked fine.

               

              Just bear in mind that Intel does not test and validate Intel® NUC on Linux; however we know that a lot of NUC owners are using it successfully on many different Linux distros, and if one of these owners might have tip on how to proceed here, please feel free to join the thread.

               

              Regards,

              Amy.

              • 4. Re: NUC5i5ryh USB headset issues
                TicoJohn

                Amy, thanks for the response. However, I think you might have missed the last post. The USB headset works, with Linux, if I use an external USB bridge between the NUC and my headset. To me, this may imply that the NUC USB ports don't have sufficient drive capability. However, as I don't have access to the design specs I can only speculate as to the cause. In any case we can consider this closed.