3 Replies Latest reply on Oct 5, 2016 11:15 AM by Intel Corporation

    Arduino IDE Boards Manager install script fails

    scutler

      Running Ubuntu 16.04 64 bit. Installed Arduino IDE 1.6.9. Hardware is Edison on breakout board. Following set up steps from IoT - Installing the Arduino* IDE | Intel® Software  and at the point where it tells you to use Boards Manager to install correct board package for Edison. Selected Intel i686 as directed - downloads appear to complete OK but then Board manager gives this error message: "Error running post install script" and in the terminal window also gives this message:

      Setting it up.../tmp/tmp.chLFdvKmso/relocate_sdk.sh /root/.arduino15/packages/Intel/tools/core2-32-poky-linux/1.6.2+1.0/i686/relocate_sdk.sh

      SDK could not be set up. Relocate script failed. Abort!

      find: invalid mode '+111'

       

      Any idea what the problem is here? And how to fix?

        • 1. Re: Arduino IDE Boards Manager install script fails
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi scutler,

           

          This issue has been reported before and we are unsure if this issue is related to the 1.6.9 IDE, the Edison board or the OS being used, we are now investigating. We’ll let you know once we have some more updates on this case. I was doing some research and encountered a thread in Spanish from the Arduino Community, Error de compilación: no entiendo por qué se produce., where a user is having a similar issue and it seems to be related to the OS, so in the meantime you could give this a try. If you do try it, let us know your results.

           

          Regards,
          -Pablo

          • 2. Re: Arduino IDE Boards Manager install script fails
            Mariox86

            Apparently the Arduino IDE install script chain is broken. Searching for this error online I found a Galileo post that tackles the problem by changing "+111" for "/111" in home/user/.arduino15/packages/Intel/tools/core2-32-poky-linux/1.6.2+1.0/i686/install_script.sh. However, after solving this and trying to upload my sketch I get a dev/ttyACM0: permission denied error. A quick fix for this is changing your permissions with sudo chmod 666 /dev/ttyACM0 or for whatever port you're using to upload the sketch, but you would have to execute the command every time you connect your Edison. You can also try to give your user permanent root privileges to the port. This finally let me upload the sketch. But the problems didn't end there. Once I tried to upload another sketch, the IDE time-outed trying to delete the previous one. Even if I delete the sketch manually by logging into my Edison the IDE would give me the same error. I gave up after this. The 1.6.9 release for Linux is seriously broken since non of its scripts seem to work correctly for the Edison board. I installed the same version for Windows earlier today and it worked like a charm, so I suggest you work on Windows for the mean time. This was under Ubuntu 16.04 64 bit.

            • 3. Re: Arduino IDE Boards Manager install script fails
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi guys,

              Thank you for your patience on this matter. We just want to let you know that this issue is in consideration for future releases of Edison Software, for now, as Mario mentioned, it would be a better idea to go with Windows when using the Arduino IDE in its latest releases.

              Regards,
              -Pablo