1 Reply Latest reply on Jul 11, 2016 9:50 AM by arunp_intel

    Interface for Telit he910 DK300 (read GPS data)

    FrancescoF

      Hi All,

       

      I'm trying to send AT command to the DK300 3G internal modem (he910) but I'm not able to find what kind of software I can use on IDP 3.1 and what is the interface used (/dev/...)

       

      Is there anybody tha can help me?

       

      My final scope is to send the AT$GPSACP command in order to read GPS position.

       

      BR

      Frank

        • 1. Re: Interface for Telit he910 DK300 (read GPS data)
          arunp_intel

          Frank,

           

          Please find below instructions for configuring telit interface. Please let us know if that helps.

           

          Thanks,

          <arun>

           

          Enabling 3G WWAN

          Enabling 3G requires configuring your board with the correct layer and template and confirming various configuration settings.

          Do not access carrier networks using unauthorized devices unless expressly authorized. You cannot use a SIM card in an unauthorized device unless you have authorization from the carrier or the applicable regulatory authority.

          Prerequisites

           

          OPTION 1 - Via Terminal:

          Before you proceed, ensure that you have configured and built your platform project.

          1. Confirm that the antenna is correctly connected to the 3G modem.

            NOTE: For the Telit HE910 modem, the SIM card holder is on the underside of the mini-PCI-e card.

          2. Deploy the kernel image and rootfs to a USB Flash drive and boot the target.
            3G starts automatically on boot.
          3. Confirm that /etc/config/network contains the correct information.Alternatively, you can use the LuCI interface to confirm this information. Start LuCI and select Network > Interfaces.This example shows sample values for the Telit HE910 and an AT&T SIM card.# cat /etc/config/network
            config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'config interface 'wan'
            option ifname 'eth0'
            option proto 'dhcp'config interface 'lan'
            option ifname 'eth1 wlan0'
            option type 'bridge'
            option proto 'static'
            option ipaddr '192.168.1.1'
            option netmask '255.255.255.0'config interface 'wwan'
            option ifname '3g-wwan'
            option proto '3g'
            option device '/dev/ttyACM0'
            option ppp_redial 'demand'
            option defaultroute '1'
            option peerdns '1'
            option service 'umts_first'
            option sconnservice 'UMTS'
            option dialnumber '*99***1#'
            option country 'us'
            option apn 'att'
            config device 'modem_cell'
            option name 'modem_cell'
            option present 'Yes'
            option protoall '3g'
            option pppddev '/dev/ttyACM0'
            option statedev '/dev/ttyACM3'
            option Manufacturer 'Telit'
            option Product 'HE910'
            option Vendor '1bc7'
            option ProdID '0021'
            option SerialNumber '357164040778055'
            option Rev '12.00.003'config device 'sim_card'
            option name 'sim_card'
            option present 'Yes'
            option IMSI '3104101123456789'
            option operator 'AT&T'
            option operator_code '3104101'
          4. Confirm that the pppoe module is present on the target.
            #lsmod | grep "pppoe"

           

          OPTION2: - Via Developent Hub

          1) Search the SSID for your device. From the "/etc/config/wireless" file, "option ssid" is your SSID and "option key" is your SSID password.

          2) After connected to your device SSID.

          3) Open you web browser and and type url "192.168.1.1"

          4) You will see Privacy Statement ( For the first time)

          5) Then, you will see login page. Enter username:root, password:root, click Go

          6) Read the License Agreement, click Agree.

          7) "Not Connected to Network" Screen appear. You can skip if you want to configure the proxy manually.

          8) You are welcome to Iot Gateway Developer Hub.

          9) Click Administration.

          10) At the left side, you can see Quick Tools. At the Setting Icon ( beside the right side of APP CLOUD )

          11) Click "Launch" button.

          12) If your we browser complaining of "Your connection is not private", Click the

          13) "Advanced" button at the below, then click "Proceed to 192.168.1.1 (unsafe)".

          14) You will come to other page on your web browser. This need "Authorization Required".

          15) Login with username:root, password:root, click the button Login.

          16) You are now at "Status" Page.

          17) At the above, choose "Network", then choose "Interfaces".

          18) Now you are at the other page, showing your LAN, WAN and WWAN.

          19) For you case with WWAN Telit HE910, you can click "Edit" for the WWAN.

          20) You will go for Interfaces -WWAN. Here you can configure your Telit HE910