2 Replies Latest reply on Jul 11, 2016 5:32 PM by Intel Corporation

    Intel 7265 no longer working after install Nvidia driver

    mrtom82

      I'm running Debian linux with kernel version 4.6.0 on a Asus GL752VW-DH71 laprop and my wireless adapter stopped working after installing the Nvidia 960m driver.  The wireless was working great prior to installing the Nvidia driver and I can't figure out what caused it to break.  I can see the wireless icon, but there are no networks to connect to and iwconfig does not show any wireless adapters, ifconfig only shows eth0 and lo. I have the latest driver installed iwlwifi-7265-17.ucode, which worked prior to the driver, but now I get the following message in dmesg:

      [ 5002.636888] Intel(R) Wireless WiFi driver for Linux

      [ 5002.636891] Copyright(c) 2003- 2015 Intel Corporation

      [ 5002.637819] 0000:02:00.0: Missing Free firmware (non-Free firmware loading is disabled)

      [ 5002.637824] iwlwifi 0000:02:00.0: Couldn't request the fw

      [ 5002.637838] iwlwifi 0000:02:00.0: Direct firmware load for /*(DEBLOBBED)*/ failed with error -2

      [ 5002.638420] iwlwifi: probe of 0000:02:00.0 failed with error -22

       

      The system appears to detect the wireless adapter just fine, but for whatever reason it does not want to load the firmware:

      rfkill list:

      0: hci0: Bluetooth

          Soft blocked: no

          Hard blocked: no

      1: asus-wlan: Wireless LAN

          Soft blocked: no

          Hard blocked: no

      2: asus-bluetooth: Bluetooth

          Soft blocked: no

          Hard blocked: no

       

      lspci |grep Wireless:

      02:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)

       

      I've tried removing and reloading the iwlwifi module using modprobe and restarting the network-manager service but it doesn't work. I completely removed the Nvidia driver, but still no wifi.  Just to make sure it wasn't something else, I reinstalled the entire OS and the wifi was working, installed the nvidia driver, rebooted and no wifi once again.  Even after completely removing the Nvidia driver, the wifi will not come back.  What could be causing this?