4 Replies Latest reply on Aug 8, 2016 8:40 PM by Intel Corporation

    Gigabyte Brix GB-BSi7HT-6500 Intel® HD Graphics 520 "No HDMI Sound+PCI Driver"

    Kevin727

      Gigabyte Brix GB-BSi7HT-6500 Intel® HD Graphics 520

       

      I have recently bought Gigabyte Brix (BS-I7HT-6500), with intel 6th generation processor i7 6500U Intel HD Graphics 520. After installing win7 64 OS + all the drivers come with manufacture Software CD. My HDMI sound still can not work(VGA output through HDMI is good with my LG smart TV). No sound comming out and dont show any HDMI sound resource. the sound jack at the front works fine as well as bluetooth audio output connection except no sound from HDMI connection. I call Gigabyte and they told me to download the newest driver version of intel graphic 520 + Intel 6th generation skylake i7 6500U processor and reinstall, but the problem is still there. My TV is LG-65UF9500 smart TV bought last year. It work fine with my 1 year old PC Brix i7H-5500 (Intel i7 5500U + Intel HD Graphics 5500) including HDMI. Please Help to solve the HDMI problem.


      Secondly I have a PCI port can not find the driver.
      Product website shown below.
      http://ca.gigabyte.com/products/product-page.aspx?pid=5786#ov

       

      Please note that, I have tried different computer and install win7 64byte & win7 32byte several times + updating newest driver from official intel website. Since The problem can not be sloved, i also update the Bios version to F2(Newest) and reinstall everything but problem still remain.

       

      Please Help to solve this problems, thank you so much

        • 1. Re: Gigabyte Brix GB-BSi7HT-6500 Intel® HD Graphics 520 "No HDMI Sound+PCI Driver"
          Hellen_Intel

          Hi Kevin727,

           

          To better understanding,

          Are you using straight connections (HDMI to HDMI)?

          Could you please explain to me this “VGA output through HDMI is good”?

           

          It is important to mention that we sell our Intel chipsets and processors to third party manufacturers and they design their own computers with their own features, settings and capabilities. For that reason they design their own drivers, to meet the exact specifications on their computers. If your computer is having problems with our generic Intel drivers, the best you can do is to install the latest customized driver released by the OEM (Original Equipment Manufacturer).

          http://ca.gigabyte.com/products/product-page.aspx?pid=5786#dl

           

          Regards,

          Hellen.

          • 2. Re: Gigabyte Brix GB-BSi7HT-6500 Intel® HD Graphics 520 "No HDMI Sound+PCI Driver"
            Kevin727

            Dear Helen:

             

            1.Yes, HDMI to HDMI Port.

            2."VGA Through HDMI is good" means I could see the display screen through HDMI to HDMI port on my smart TV but no sound.

            3.I install all the Driver that Gigabyte provided not just from Original OEM driver disk but also from their official website,

               Still no sound & missing 1 PCI Driver.

             

            I did contact Gigabyte but they said its VGA problem from Intel, so they asked me to download latest version of Graphic driver on Intel 520.

            and still not working nor PCI driver.

             

            For the last few days, I have tried several ways to see what went wrong, and I found the sound output problem was caused by newest updated Bios version "F2" (If I dont updated to F2 the Thunderbolt can not be used).The Original setting for Bios "F2" from Gigabyte "Disable" LAN PXE OpROM,

            so when you turn it to "Enable" the sound works fine with HDMI output.

             

            But the other problem also appear as following.

            1.BIOS: TPM2.0, when it is on "enabled" , when restart/turn on the PC, Screen stuck at window starting screen and no matter how long you wait,

               it wouldnt login to Desktop, the screen stuck at the log"ing" process with window logo circling around.

            2.NVME driver device was Not found.

            3.PCI driver still missing with Location PCI 0, 22, 3. (Do you know what driver used to be installed at this location?)

            • 3. Re: Gigabyte Brix GB-BSi7HT-6500 Intel® HD Graphics 520 "No HDMI Sound+PCI Driver"
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Dear Kevin727,
               
              It looks like the audio is working depending on the BIOS settings you use so we know for a fact that it is not a graphics issue but a BIOS bug. What I did notice is that if you change something in the BIOS, another features stop working, which means that the BIOS is not working as it should.
               
              The PCI driver missing on the system gets installed with the chipset driver, which it’s provided by Gigabyte.
              What I would recommend you if this was an Intel® NUC is the following:

              • Test it with another HDMI cable, as much as possible HDMI 1.4a high-speed cable.
              • If the thunderbolt port is not used very often you could try doing a BIOS downgrade.
              • If possible try a clean installation of the OS in case some entries of the registry are corrupted.
              • Report all those bugs on the BIOS with the manufacturer, to make the corresponding improvements.
               
              Regards,
              Hellen.
              • 4. Re: Gigabyte Brix GB-BSi7HT-6500 Intel® HD Graphics 520 "No HDMI Sound+PCI Driver"
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hi Kevin727,
                 
                I have been checking this thread and I was wondering if the information provided helps you.
                If there is anything else you need, do not heisted to contact us back.
                 
                Regards,
                Hellen.