6 Replies Latest reply on Jul 29, 2016 9:44 AM by Intel Corporation

    Intel DX58SO2 No POST - Blank Screen

    mackinney78

      I am a newbie so this could be something really simple. I purchased this board to replace another mobo that had a bad USB chipset. All components (HD, video card, CPU, DVD ROM. PSU) were all working fine on other motherboard - just USB chipset was shot.

       

      After installing the new board and powering up the PC, I do not get any display. The monitor doesn’t seem to receive any signal. The 80h POST code displayed is 14 (according to the manual that is LAN init).

       

      Here is what I’ve tried so far:

      -checked the CPU for bent pins

      -reapplied thermal grease

      -replaced all mobo screws and case studs

      -tried the PCI-e video card in each of the slots

      -pulled all the RAM out and tried to boot (no error beeps...this really concerns me because I was under the impression that I should get some beeps)

      -swapped HD SATA cable to other SATA ports

      -removed and reseated the CPU and motherboard

      -disconnected and reconnected all power cables

      -rechecked all cables are connected to the mobo correctly

       

      Can someone please offer some assistance?

       

      Thank You!