4 Replies Latest reply on Jun 30, 2016 1:31 PM by Intel Corporation

    Power surge on the USB port - Intel NUC 515RYH

    Adren

      Hello.

       

      I'm using Intel NUC 515RYH for about 6 months now. Few days ago, I started getting error prompt "Power surge on the USB port". It keeps prompting and stop for a minute and then prompt again.

       

      I've tried the following steps to resolve this problem.

       

      1. Remove all USB connection and reboot. I still get the error.

       

      2. Reset my Windows 10 to factory default, deleting all apps. I still get the error.

       

      3. Updating to latest bios. No help.

       

      4. Removing ever item from USB controller at Device Manager and reboot. No help.

       

      5. Reset and reboot hundreds of times. Including disconnecting the power cable and drain out all the reserve power in the NUC.

       

      FYI, I tried connecting USB devices to all 4 ports and it works perfectly.

       

      I just need to find a way to stop this annoying prompt.

       

      Capture.PNG

       

       

      Sounds like a hardware failure to me, what do you guys think?