4 Replies Latest reply on Sep 23, 2016 7:55 AM by GJHinchliffe

    My laptop will not let me rotate screen with Intel HD 4000 Graphics

    wonderingguy

      I have a monitor I would like to rotate. There is no option to do it in the display menu.

       

      2kILN.png

      I have an Intel (R) HD Graphics 4000.

      I downloaded the updated drivers from Intel although when I tried to install them it said they were not validated for this computer.

      Googling that brought a lot of results from other people with the same issue. It seems the manufacturer can put weird drivers on your computer and prevent you from installing other ones. I tried to manually install them and it didn't work. I would think that they wouldn't need to prevent someone from rotating the monitor but I don't know.

       

      I am running Microsoft's Windows version 8.1 64bit.

       

      ASUS laptop.  It is S200E

       

      I changed the registry values: Display1_EnableIndependentRotation

      Display1_IndependentRotation

      Display1_PortraitMode

      Display1_RotationCaps

      Display2_PortraitMode

      Display2_RotationCaps

       

      From 0 to 1.

       

      It did not correct.

       

      Then I changed

       

      Display1_DisableAsyncFlips = 0 (was 1)

      Display1_RotationCaps = 7

      Display2_RotationCaps = 7

       

      Doing that did not let me rotate the screen, either.

       

      On a different forum someone said this worked for them.

       

      I am worried about uninstalling all the company drivers and replacing them with intel ones.  What if I cannot get it to how it was when I got it?

       

      What can I do to rotate my screen?

        • 1. Re: My laptop will not let me rotate screen with Intel HD 4000 Graphics
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello wonderingguy,
           
          Try accessing the Intel® Control Panel and rotate 0, 90, 180 and 270 from there, the Intel® graphics does not work from where you want to do it.
           
          In desktop mode, right-click on the Desktop, and select Graphics Properties or from the Windows desktop, press Ctrl Alt F12 to open the Intel Graphics Control Panel.
           
          Once the Intel Graphics Control Panel is open, click on “Display” and then select multiple displays, you will see rotation option.
           
          About the Intel® generic driver installation:
          The message “this driver is not validated for this computer” indicates that your computer manufacturer does not allow the installation of generic Intel video drives. You are required to install drivers from your computer manufacturer; however, you may try forcing the installation of Intel generic drivers by performing manual procedure, see here for instructions: How to Manually Install an Intel® Graphics Driver in Windows® 10 &…
           
          You will need to uninstall the old driver first and disconnect the internet.
           
          Once the driver is uninstalled you can go ahead and manually install the latest graphics driver, you can download it here:
          https://downloadcenter.intel.com/download/25977/Intel-Graphics-Driver-for-Windows-10-and-Windows-7-8-1-15-33-?product=81499
           
          Note: Once you install the “generic” driver you will overwrite any customizations your system manufacturer made to the driver specific for your system model.
           
           
          Regards,
           
          Ivan
           

          • 2. Re: My laptop will not let me rotate screen with Intel HD 4000 Graphics
            wonderingguy

            The option to rotate is not in the Intel menu.

             

            2yl8di1.png

             

            I noticed this:

             

            2h5lbaf.png

            • 3. Re: My laptop will not let me rotate screen with Intel HD 4000 Graphics
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Did you install the driver manually that I advised above?
               
              Did you uninstall the older driver?
               
              If yes, this is most likely because your system manufacturer does not allow this configuration, they may have modified this option and it is not available for your system.
               
               
              Regards,
               
              Ivan
               

              • 4. Re: My laptop will not let me rotate screen with Intel HD 4000 Graphics
                GJHinchliffe

                Hi wonderingguy,

                I have exactly the same laptop as you, and I'm also having a very similar problem.

                 

                Here is some background information about my problem:

                I recently refreshed my computer to give it a fresh start and increase the speed at which it runs. Consequently this meant that the pre-installed drivers (which definitely allowed me to rotate my screen) were removed in the process. After I had completed the Windows 10 install I checked the ASUS website (https://www.asus.com/Notebooks/ASUS_VivoBook_S200E/HelpDesk_Download/) for graphics drivers, and although they didn't have an option for windows 10 I downloaded and installed the Windows 8 one. This driver worked just fine, that is until I wanted to rotate the screen: it has no option for that. I then proceeded to try and install the driver on the Intel website (the one recommended to you above), however I got the same error as you (not validated for this computer).

                 

                I then went to Control Panel > Programs > Programs and Features and uninstalled the Intel Graphics Driver which I got from ASUS. After a restart I took the following steps right-click on Desktop > Display Settings and was presented with screens like this (please note the Orientation option):

                 

                Despite the fact I now had the option to rotate my screen, this setup was pretty useless to me because my HDMI and VGA ports wouldn't work. And anyway, after a few minutes some Intel drivers were automatically installed, giving me the following screens:

                 

                I then tried installing the Intel drivers recommended to you again, and this time they installed without an error. This still hasn't solved my problem however, because I still don't have the option of rotating my display.

                 

                I realise that I haven't actually solved your issue either, but I am wondering if your issue has how been solved (and if so how) and also I hope I've brought a bit more information to the situation.