1 2 Previous Next 18 Replies Latest reply on Aug 22, 2016 9:12 AM by Intel Corporation

    Core i7-5775C won't display 4K@60Hz

    ASM

      I just upgraded my CPU from a i7-4790 (non-K) to an i7-5775C on an ASUS Z97-WS motherboard.

       

      The Z97-WS has been connected to an Acer B286HK 4K/60Hz monitor for a year.

       

      The Haswell i7-4790 had no problem displaying 4K/60Hz/DP1.2 on its DP and miniDP ports.

       

      The 5775C is now defaulting to 4K/30Hz on both DP ports despite the monitor being in DP 1.2 mode (unchanged).

       

      I'm running driver 20.19.15.4463.  I also tried the previous .4444 driver with the same result.

       

      Situation:

       

      • The same cable and monitor worked with the Haswell 4790 CPU, Quadro K620, GTX 980 at 4K/60Hz.
      • The same cable and monitor worked with the somewhat similar NUC 5i5RYH / HD6000 at 4K/60Hz.
      • I see that my workstation reports a video BIOS of 1029 while the NUC 5i5RYH has a video BIOS of 1039.
      • Additionally, the workstation used to be able to display the UEFI BIOS interface on the 4K monitor but the 5775C doesn't display anything until Win10/x64 fully boots.
      • Platform: Win10/x64 + Acer B286HK 4K/60Hz + Core i7-5775C

       

      So... what's the problem?  Is the motherboard BIOS's Intel Video BIOS too old and I need ASUS to upgrade it?

       

      I really need this fixed as it's my daily workstation.

       

      5775C_Video_Bios.png

      NUC5i5RYH_Video_BIOS.png

      30Hz.png

       

      The EDID dump of the Acer B286HK is here:

      acer_edid.png

        1 2 Previous Next