2 Replies Latest reply on Oct 17, 2016 10:38 AM by dcbrian

    Edison USB Connection to OS X Acting Strange

    dcbrian

      I fear this may actually pertain more to OS X itself and not so much to Edison, but I'll start here.  I'm running OS X 10.11.5. and the iot-devkit-prof-dev-image-edison-20160315 image on the Edison.  I added the driver for OS X networking to recognize the Edison as a service under the label "Edison", programmed the service to use 192.168.2.2/24, and all was working great.  The Edison itself of course has the address 192.168.2.15/24.

       

      Having two Edisons, I thought to myself that I'd like to connect both to my Mac at the same time.  I connect the second Edison, OS X immediately created a second networking service named "Edison 2".  I assigned the Mac side address to 192.168.2.3/24 and the second Edison to 192.168.2.16/24.  Two problems arose.

       

      Problem 1: Every time I now restart either of the Edisons, whether both USB-connected simultaneously or just one, OS X doesn't reuse the existing Networking service "Edison" or "Edison 2".  Instead it creates a new service, "Edison <N>", where N is the highest existing Edison service +1.  E.g. If an "Edison 5" network service exists, it adds an "Edison 6", which I have to assign an IP address and mask each time.  I would like for the Edison to recognize the last used networking service, as if previously did, instead of creating a new one with each startup.  I've tried rebooting and re-setting the PRAM.

       

      Problem 2: OS X does not seem to properly update its routing table with the onset of the second Edison, by examining the "netstat -rn" output.  I attempted some "route -n add ..."/"route-n delete ..." commands, but they failed.  Nonetheless, this is an item of lower interest, so I'm not terribly concerned with it over not having to re-enter the IP config after each Edison restart.

        • 1. Re: Edison USB Connection to OS X Acting Strange
          dcbrian

          After reading through this site, I found the answer to Problem 1.

           

          HoRNDIS: USB tethering driver for Mac OS X | Joshua Wise's domain

           

          Basically, delete (or rename as I did) the following files:

          /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist

          /Library/Preferences/SystemConfiguration/preferences.plist

           

          This worked for me, but be forewarned that they say that this will cause you to lose any custom network configuration.  I tried editing these files by just removing any entries (XML entries) references to Edison, but that didn't change anything.

           

          Problem 2 I'm probably not going to try to solve, as it's not terribly important for me, just something I wanted to try.

          1 of 1 people found this helpful
          • 2. Re: Edison USB Connection to OS X Acting Strange
            dcbrian

            Quick follow-up: this problem has re-occurred with other non-Intel devices that rely on the HoRNDIS driver, and in those cases, I was able to just remove the XML elements designated for the RNDIS entries, and that solved problem #1.

             

            In NetworkInterfaces.plist delete each 'dict' element for an RNDIS device.

            In preferences.plist delete each 'dict' element for an RNDIS plus the preceding 'key' element.

             

            That should put you on a clean slate w.r.t. RNDIS.  I highly recommend backing up those files before editing.  I presume this would work just the same as the Edison.

             

            I still haven't figured out a way to have two or more of the same device type connected to the same host without triggering this problem.