7 Replies Latest reply on Jun 23, 2016 1:20 PM by Intel Corporation

    Flashing Edison from Windows

    Peter-H

      I'm trying to flash the Edison module from Windows.

       

      This is the serial port output on the module before I tried flashing it.

       

      ******************************

      PSH KERNEL VERSION: b0182b2b

                      WR: 20104000

      ******************************

       

      SCU IPC: 0x800000d0  0xfffce92c

       

      PSH miaHOB version: TNG.B0.VVBD.0000000c

       

      microkernel built 11:24:08 Feb  5 2015

       

      ******* PSH loader *******

      PCM page cache size = 192 KB

      Cache Constraint = 0 Pages

      Arming IPC driver ..

      Adding page store pool ..

      PagestoreAddr(IMR Start Address) = 0x04899000

      pageStoreSize(IMR Size)          = 0x00080000

       

      *** Ready to receive application ***

       

       

      Then I closed the serial connection.

       

      The image was downloaded from here

      https://downloadmirror.intel.com/26028/eng/iot-devkit-prof-dev-image-edison-20160606.zip

       

      Unzipped it and also downloaded dfu-util from and placed the .exe in the unzipped directory.

      https://communities.intel.com/servlet/JiveServlet/download/25154-6-102797/dfu-util.exe.zip

       

      Started cmd as Administrator and ran flashall.bat

       

      Using U-boot target: edison-blankrndis

      Now waiting for dfu device 8087:0a99

      Please plug and reboot the board
      Dfu device not found Timeout
      Did you plug and reboot your board?
      If yes, please try a recovery by calling this script with the --recovery option

       

      Then I rand flashall.bat --recovery

       

      Starting Recovery mode

      Please plug and reboot the board

      Flashing IFWI

      !!! You should install xfstk tools, please visit http://xfstk.sourceforge.net/

      But xfstk appears to only be available for linux.

       

      I also tried the Windows installer found here

      IoT - Intel® Edison Board Download | Intel® Software https://software.intel.com/en-us/iot/hardware/edison/downloads

       

      The installer finished installing some drivers but at the flashing stage it never detected the device so I could click next to flash it.

       

      Would finding an xfstk solve my issue, where can I find an official version of it?