4 Replies Latest reply on Jun 22, 2016 9:37 PM by Intel Corporation

    OpenZWave on Edison

    scostello

      I'm trying to set up OpenZWave and the OpenZWave Control Panel on my Edison Kit for Arduino so I can use the UPM wrapper for the OpenZWave library. I'm having trouble getting OpenZWave on my Edison; all the tutorials I have found are for Raspberry Pi's and I haven't been able to get them working. Does anyone know how to do this or have a tutorial I could follow?

        • 1. Re: OpenZWave on Edison
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi scostello,

          What have you tried so far? Could you please share the tutorial(s) that you’ve been following to see your process? Personally, I would recommend you to install it using the AlexT repository, I just checked it and OpenZWave is available. If you haven’t installed packaged using this repository, here you can find the instructions on how to configure your Edison http://alextgalileo.altervista.org/edison-package-repo-configuration-instructions.html. And the OpenZWave package is located in here http://repo.opkg.net/edison/repo/core2-32/.

          Regards,
          -Pablo

          1 of 1 people found this helpful
          • 2. Re: OpenZWave on Edison
            scostello

            I was able to get the control panel running using this tutorial https://lickthesalt.com/2016/04/11/compiling-open-zwave-control-panel-on-a-raspberry-pi-3/. However when I try and Initialize on the control panel with the USB checkbox checked and leaving the device name blank I get

             

            2016-06-15 19:31:15.326 Always, OpenZwave Version 1.4.291 Starting Up

            webserver starting port 8888

            post: key=dev data= size=0

            post: key=fn data=open size=4

            post: key=usb data=true size=4

            2016-06-15 19:31:22.416 Info, Setting Up Provided Network Key for Secure Communications

            2016-06-15 19:31:22.416 Warning, Failed - Network Key Not Set

            2016-06-15 19:31:22.417 Info, mgr,    Added driver for controller HID Controller

            2016-06-15 19:31:22.417 Info,  Opening controller HID Controller

            2016-06-15 19:31:22.417 Info,    Open HID port HID Controller

            2016-06-15 19:31:22.419 Error, Cannot find specified HID port with VID:1b5f and PID:0x0001. 2016-06-15 19:31:22.420 Error, Enumerating connected HIDs:

            2016-06-15 19:31:22.421 Error, Failed to open HID port HID Controller

            2016-06-15 19:31:22.421 Error, HIDAPI ERROR STRING (if any): (null)

            2016-06-15 19:31:22.422 Warning, WARNING: Failed to init the controller (attempt 0)

            2016-06-15 19:31:27.422 Info,  Opening controller HID Controller

            2016-06-15 19:31:27.423 Info,    Open HID port HID Controller

            2016-06-15 19:31:27.475 Error, Cannot find specified HID port with VID:1b5f and PID:0x0001. 2016-06-15 19:31:27.476 Error, Enumerating connected HIDs:

            2016-06-15 19:31:27.477 Error, Failed to open HID port HID Controller

            2016-06-15 19:31:27.477 Error, HIDAPI ERROR STRING (if any): (null)

            2016-06-15 19:31:27.478 Warning, WARNING: Failed to init the controller (attempt 1)

            2016-06-15 19:31:32.479 Info,  Opening controller HID Controller

            2016-06-15 19:31:32.479 Info,    Open HID port HID Controller 2016-06-15 19:31:32.533 Error, Cannot find specified HID port with VID:1b5f and PID:0x0001.

            2016-06-15 19:31:32.534 Error, Enumerating connected HIDs:

            2016-06-15 19:31:32.534 Error, Failed to open HID port HID Controller

            2016-06-15 19:31:32.534 Error, HIDAPI ERROR STRING (if any): (null)

            2016-06-15 19:31:32.534 Warning, WARNING: Failed to init the controller (attempt 2)

            2016-06-15 19:31:37.536 Info,  Opening controller HID Controller

            2016-06-15 19:31:37.537 Info,    Open HID port HID Controller

            2016-06-15 19:31:37.592 Error, Cannot find specified HID port with VID:1b5f and PID:0x0001. 2016-06-15 19:31:37.593 Error, Enumerating connected HIDs:

            2016-06-15 19:31:37.593 Error, Failed to open HID port HID Controller

            2016-06-15 19:31:37.593 Error, HIDAPI ERROR STRING (if any): (null)

            2016-06-15 19:31:37.593 Warning, WARNING: Failed to init the controller (attempt 3)

            2016-06-15 19:31:42.594 Info,  Opening controller HID Controller

            2016-06-15 19:31:42.628 Info,    Open HID port HID Controller

            2016-06-15 19:31:42.629 Error, Cannot find specified HID port with VID:1b5f and PID:0x0001. 2016-06-15 19:31:42.630 Error, Enumerating connected HIDs:

            2016-06-15 19:31:42.630 Error, Failed to open HID port HID Controller 2016-06-15 19:31:42.630 Error, HIDAPI ERROR STRING (if any): (null)

            2016-06-15 19:31:42.630 Warning, WARNING: Failed to init the controller (attempt 4) 2016-06-15 19:31:42.631 Detail, contrlr, Notification: DriverFailed

            2016-06-15 19:31:42.631 Info, Notification: Driver Failed, homeId 00000000

             

            I have the Aeotech Z-Stick Gen5 connected to the USB port of the Edison board.

            • 3. Re: OpenZWave on Edison
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi scostello,

              Regarding the compilation of OpenZWave control panel on the Edison, were you able to install all the necessary libraries? Which repository or method did you use to install these libraries? I would like to reproduce it myself so if you did anything different from the Raspberry tutorial please let me know.
              Also, did you install the Z-Stick drivers on your Edison? I found a link that you might find useful http://www.homegenie.it/forum/index.php?topic=606.0. According to the thread there are some drivers available for these Z-Sticks, they don’t mention Gen5, but they do work with the S2 so I would suggest you to check it.
              Also, check this thread https://community.home-assistant.io/t/tutorial-compiling-open-zwave-control-panel/581/9. Take a look at JoeDSM, he is having a similar error and was able to solve it.

              Regards,
              -Pablo

              • 4. Re: OpenZWave on Edison
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hi scostello,

                Do you have updates on this case?

                Regards,
                -Pablo