5 Replies Latest reply on Jun 20, 2016 9:15 PM by Intel Corporation

    Intel PRO1000/PT network card not showing up on PCIe bus one certain systems

    TheUnnamedNewbie

      I also posted this message on the motherboard manufacturers forum. If this is not the right place to put it, my apologies.

       

      So I got myself an intel pro 1000/pt quad port network card, but it doesn't get detected by my motherboard. Here is a nice list of the what I've done, and what I've found:

       

      When I say "it doesn't get detected" I mean the following: First time I installed it, and booted into windows 10 enterprise, it didn't show up in device manager (I also selected the "Show hidden devices" under "view" in device manager).

      I didn't quite know what was going on then, so I grabbed a debian jessie live USB, booted into that. Neither "lspci" or "dmesg" mentions anything about seeing the device (so not even something like "failed to start" or other error conditions).

      So finally I went into my bios "hardware monitor" thing, and it didn't show the PCIe slot it was in as containing anything.


      Every time from now on I try something and it doesn't help, it means I went though the above three steps.

       


      I've tested the network card in 2 other systems where it was fine
      : A supermicro server (Debian jessie, 2 xeon's - socket 1366, 64 gb ram, ...) and an Lenovo/emc storcenter (core2duo iirc, don't ask me what OS, it's something debian based). In both of these systems the card works just fine (well, I did only test debian on those systems since they can only suffer short periods of downtime, and I'm not in the mood to try and get windows running on either). The card thus works.

       

      I've repeated this test a few times just to see that the card didn't die along the way, but it still works fine in those.

       

      So here are the things I tried to fix it:

      -Installed newest bios version (1.B) from the motherboards support page.

      -Tried different PCIe slots - First I tried it in PCI_e3 according to the motherboards manual. After that, I tried every other slot that wasn't 1x.

      -Swapped the GPU with the card (so, I put the gpu in PCI_e3, and the NIC in PCI_e1)

      -Manually forced the PCIe gen of the slot the card was in to gen1 and gen2

      -set the pci latency timed to 64 instead of 32 (while I've never, ever had to manually play with those (and I've built hundreds of systems), I was getting quite desperate at this point).

      -I then tried all of the above shuffling around with system wake on PCIe device turned on

      -Tried all the above with the intel onboard network adapter forcefully disabled

      -Tried 2 other RAID controller cards, which all just work fine first-time (this to rule out something stupid going on with my CPU not wanting to do /any/ other pci device).

       

      Oh, and all of this is without any overclock, the first thing I do when anything is acting up is set the overclock settings to default.

       

      System specs:

      Board: x99s SLI PLUS

      BIOS:  1.B, as per the latest on the motherboards webpage

      VGA:   AMD R9 280x

      PSU:  Corsair RM1000

      CPU:  i7 5820k, default clocks

      MEM: 4x8gb Crucial DDR4 (nothing fancy, if you really need it I'll go look for model numbers) - running stock speeds and all that
      HDD/SSD
      : 2 Adata SSD's

      OS: Windows 10 64bit enterprise, Debian Jessie

       

      Anything else you guys suggest trying? If I can't get it fixed, I'll get a replacement board. My main worry is that it has nothing to do with my board specifically, but something like an odd compatability-clash between this board model and that card, in which case that will be to no avail, and I'm also not willing to shell out /even more/ for a newer model network card and risk that one not working either.