3 Replies Latest reply on Jun 11, 2016 1:01 AM by ngongca

    Unable to ping from Gen2

    Xiaoyu

      Hello everyone,

       

      I am a student and new to Galileo, the question may be quite simple, but I can't find a solution even I googled two days.

      To get started, I followed the first three steps on IoT - Step 1: Make a bootable micro SD card | Intel® Software

      So  I had a serial connection to the board and I can login the Linux system as a root. Then I plugged in the Ethernet cable into the port on the board and did "ifconfig" through Putty, I got the IP address "192.168.203.181". I noted it down and later did the SSH, however there was no response. I tried to ping "www.google.com" from the board, it failed either. I did some search and some say that an Arduino sketch is needed to enable Ethernet, do I have to do this?  Please help on this, thanks so much.

       

      Regards,

      Xiaoyu

        • 1. Re: Unable to ping from Gen2
          FGT

          Hi Xiaoyu,

           

          I just replied in the other thread you posted this question. Now I wonder if Galileo is really booting from the SD Card... please send a screen capture of the Galileo grub options at startup or at least the number of options it shows.

           

          Fernando.

          1 of 1 people found this helpful
          • 2. Re: Unable to ping from Gen2
            Xiaoyu

            Hi Fernando,

             

            Thanks for your quick response firstly! Your reply on the other thread help me a lot. For the ping issue, I tried to ping to an IP address rather than a host name and it works! And for the ssh, I made it by typing "root@192.168.x.x" in putty, but if I simply type the address "192.168.x.x" there is no response. Still working on the reason. Thanks so much for your help again!!

            • 3. Re: Unable to ping from Gen2
              ngongca

              Xiaoyu,

               

              I just had the same issue.  Seems that my DNS server was not set.  Use connmanctl to set up your nameservers and it works.

               

              root@galileo:~# connmanctl services

              *AO Wired                ethernet_984fee01869a_cable

               

              This provided me the right service.  I then used the service to set the name server. The nameserver I used was my router address.

              root@galileo:~# connmanctl config ethernet_984fee01869a_cable --nameservers 192.168.0.1

               

              Hope this helps.

              1 of 1 people found this helpful