4 Replies Latest reply on Jun 8, 2016 2:32 PM by Intel Corporation

    Network reading slower than writing with AC-7260

    Boeboey

      I just got a new Asus N751JX laptop with an Intel Dualband Wireless AC-7260 network adapter.

      I tried to playback a full HD animation movie from my NAS but it's stuttering like hell.

      I never had this problem with my 7-year old laptop.

       

      My router is a Linksys WRT320N. And I'm connected via 2,4GHz.

      My NAS is a Synology DS415+, so fast enough to handle the job

       

      I download LAN Speed Test (lite) and tried to transfer 30MB.

      Writing speed: 49 Mbps

      Reading speed: 23 Mbps

       

      It's really strange that reading speed is lower than writing speed.

      I would expect the opposite.

       

      Whet I tried until now:

      1. Installed latest version/patches of Windows 10

      2. Upgraded BIOS to latest versin

      3. Installed latest version of Intel driver (18.33.0.2)

      4. I also tried the latest driver from the ASUS website

      5. I followed the recommendations on the Intel website about the advanced wifi settings

      6. I also tried to disable my Bluetooth

       

      The speed/strength of my connection is varying between 60 and 180Mbps.

      How can I increase the reading speed to an acceptable level?

      And how is it possible that reading is slower than writing?

      I already tried several suggestions from other forum topics but nothing works.

        • 1. Re: Network reading slower than writing with AC-7260
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Boeboey,

          Is this issue happening only with an specific movie? How about accessing other data?
          Intel recommends to always use the latest drivers provided by the computer manufacturer, in this case, ASUS* It is important to check with them for the latest drivers. You may find their contact information here: Computer Manufacturer Support Websites

          It is also important to verify with Linksys* if your router is also running the latest firmware. Through this link, you may find additional information and support: Linksys* Support for the 
          Dual-Band Wireless-N Gigabit Router WRT320N


          In the meantime, you are welcome to try the following steps that might help you improve your speed.

          1. Disable the Power saving Functions. Go to Control Panel >> Hardware and Sound >> Power Option >> Set the High Performance and apply to default settings.
          2. Next, check the Change Plan Settings >> Change Advanced Power Settings >> Wireless Adapter >> Power Saving Mode and maje sure both on battery and Plugged in are set to Maximum Performance.
          3. Also, go to Device Manger >> Network Adapters >> Intel® Dual Band Wireless-AC 7260, right click on it and select Properties.
          4. Once you're there, please select the tab that says Advanced and from the options available, look for the option that says U-APSD support and set it to disabled.
          5. The following, find Transmit Power option and set it to 5. Highest.
          6. Set the Wireless Mode to 802.11a/b/g. *Importanto to assure that the wireless mode on the router matches that of the adapter's.
          7. Set the preferred band to Prefer 2.4GHz band.
          8. Set the HT Mode to HT Mode.
          9. Set the channel width for 2.4GHz to limit 20MHz.
          10. Set the value of Roaming Aggressiveness to Lowest.
          11. Set the value of Ad Hoc QoS Mode to WMM Disabled.
          12. By default, routers come with the channel set to 11 or 6 and sometimes they get crowded. You way want to try a less crowded channel for better performance.

          Let us know if these steps above helped you resolving this situation.


           

          • 2. Re: Network reading slower than writing with AC-7260
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            BoeBoey,

            We haven't heard from you for a while so we would like to know if you still need our assistance. Please let us know as soon as you can.

            • 3. Re: Network reading slower than writing with AC-7260
              Boeboey

              Thanks for the tips you suggested.

              But I chose the easiest solution.

              I bought a new router that is able of handling 2,4GHz and 5GHz at the same time.

              Now my read/write tests are as expected now (read speed > write speed).

              So the problem was probably related to my old router.

              • 4. Re: Network reading slower than writing with AC-7260
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Boeboey,

                Thanks for your time in letting us know that the situation has been resolved after a new router was installed. Should you have any questions or doubts, please do not hesitate to contact us.
                Have a great week!

                regards,

                Aleki