10 Replies Latest reply on Jun 3, 2016 4:28 PM by Lutfij

    Intel 82566DC-2 not functioning, questions

    Lutfij

      Hey there,

       

      I'm quite well versed with issues pertaining wired and wireless networking but this issue has had me stumped for quite a while - almost a week. I tried creating an account on these parts but was denied access until today. Thankfully I've managed to create an account and hope that the issue could come to some manner or form of disclosure.

       

      First off system's specs:

      Intel E6750 @ stock w/stock(copper slugged) cooler

      Intel DG33FB

      2x1GB Transcend DDR2 ram sticks

      1x 160GB Seagate HDD

      1x 640GB Samsung HDD

      1x Asus DVD Writer
      Windows 7 Home Premium 64bit

      400W cheap PSU

      El cheapo Chinese Chassis

       

      The system belongs to a friend of mine and while I was instructed to perform a reinstall of Windows 7 on the machine, I thought I'd try and update the rest of the internals by either

      a| BIOS updates

      b| latest software/drivers meant for the board

      c| make the onboard LAN active even though the system is connected wirelessly via a USB dongle.

      or all the above.

       

      Upon scouring Intel's product support page, I managed to update BIOS from version 0216 to version 0572 while I was able to pool the latest drivers from the aforementioned support site with a few more off here and there. Realtek had the latest audio drivers so that is where I naturally sourced the latest drivers. An issue became apparent when I couldn't log on to the www in spite of having an ethernet wire hooked to the ethernet port. I could clearly see that the power status LED was well lit(green) though the second status LED was not showing any form of activity. Mind you the drivers used for the Intel ethernet adapter was Intel Pro v20.1. I figured that the drivers might be the issue here, proceeded to uninstall and then reinstall the drivers using a previous version v15.3 but the same issue presented itself. I went over to Device Manger and there I see a device under the Networking tab with a yellow exclamation mark flagging an issue. Upon right clicking and entering into properties, the first tab showed that the device cannot start with an "error code 10" displayed. If I disabled the NIC in Device Manger and tried to find a solution in Network adapter settings, I notice that the device pops up but is shown to be disabled. In excitement I enabled the device in Network Manager but upon a refresh the device disappears.

       

      When disabled I can right click on the NIC and sift through it's properties albeit are inactive/greyed out. I've tried uninstalling the device drivers from both Device Manger and Control Panel while using device driver files found off a Microsoft WHQL driver pack v17.4(courtesy of Intel) and although the drivers for the culprit NIC is installed with 82566DC-2 being detected I'm unable to get any use out of it. With the NIC enabled and showing the yellow exclamation mark, I ran ipconfig/all in an elevated CMD and couldn't find the NIC. I double checked by connecting the Realtek USB wireless dongle and the dongle popped up without flinching. I also tried pinging 127.0.0.1 with the same results always and there is no data loss. I've also removed CMOS battery for 30+mins before replacing it yet no dice. Why is this behaving like that? I did clean out the ethernet port using a cotton swab and some isopropyl alcohol, cleaning it off of lint and dust.

       

      I'm stumped at this issue and can't get the system to log onto the internet since my router just gave up the ghost. I've disabled the NIC in BIOS while removing traces of the drivers files on the OS. I will perform a clean install again if necessary although I've done it 3 times. Ruled out a corrupt installer and recreated the installer multiple times with an ISO I had back when Windows 7 was available from Digital River. If there is some form of disclosure to this madness then I'd be grateful for the time input to this thread. I don't mind leaving it disabled but I'd like to pass on the news to my friend due to reasons of trust.

       

      Best Regards,

      Lutfij

        • 1. Re: Intel 82566DC-2 not functioning, questions
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi Lutfi,

           Thank you for the post. Can you try disabling or removing the wireless dongle first when you install the LAN driver for the 82566DC-2 ethernet controller.  Please try using the LAN driver for DG33FB board again to test ( which I understand you did use this version) https://downloadcenter.intel.com/download/19059/LAN-Intel-PRO-Network-Connections-Driver-for-Intel-Desktop-Boards-for-Windows-7-
            As this is an onboard NIC for the DG33FB board, I will forward your concern to the board support to further assist on this.

          Thanks,
          wb

           

          • 2. Re: Intel 82566DC-2 not functioning, questions
            Lutfij

            Hi wb,

             

            Thank you for a response. In hindsight, I've tried using v15.1(a much older drivers found off Intel's DG33FB support page) as well as v15.3(the on you've linked) with no progress whatsoever. I would also like to add that I've tried installing the OS without the wireless dongle connected so the issue with the NIC began off the bat. I did connect tot eh internet using the wireless dongle to see if Windows updates had something different to say about it but no drivers came up. One more thing, I get error code 10(device cannot start) or error 21(which I can't remember what it said) If you'd like I can fire up the system and source the error code when NIC is disabled.

             

             

            Thank you for passing on the news around the community It's much appreciated. I'd much love to learn if the NIC is dead or needs a magic trick to get it to work.


            Regards,

            Lutfij

            • 3. Re: Intel 82566DC-2 not functioning, questions
              N.Scott.Pearson

              Use F2 to enter into BIOS Setup and click on the entry (on the main page) titled "Additional System Information". At the bottom of this page (you may have to scroll down), there should be a display of two things, (1) the Management Engine (ME) firmware revision and (2) the MAC Address for the on-board Ethernet Solution.

               

              If the ME firmware revision is blank or is displayed as 0.0.0.0 or if the MAC Address is displayed as 00-00-00-00-00-00 or FF-FF-FF-FF-FF-FF, then something has gone wrong during a previous BIOS update operation (this can happen if the BIOS revisions are too far apart; 215 and 572 were very part apart!). What you should do in this case is install the latest BIOS using the recovery method. If this restores the values, great. If not, the board may need to be replaced.

               

              ...S

              • 4. Re: Intel 82566DC-2 not functioning, questions
                Lutfij

                Hi there Scott,

                 

                I just fired up the system and did as you've instructed me to, upon entering "Additional System Information", Intel ME firmware shows as 3.2.3.1037 but I can't seem to find the MAC address displayed therein. In my defense I did update the BIOS incrementally with the 3 BIOS files available from Intel's support site leading up to 572. I also thought of enabling the onboard NIC and reboot the system to get into BIOS and see if the MAC were displayed in BIOS but to no avail.

                 

                Regards,

                Lutfij

                • 5. Re: Intel 82566DC-2 not functioning, questions
                  N.Scott.Pearson

                  Hhmmm, I have only dumb questions at this point. First of all, have you verified whether the LAN interface is actually enabled in the BIOS? Look in the Configuration / Onboard Devices scene...

                  • 6. Re: Intel 82566DC-2 not functioning, questions
                    Lutfij

                    Believe you me Scott, I've had this system for almost 2 weeks and the same questions come across my mind on whether what I'm doing is right or not. To answer the question, yes, the NIC is enabled in BIOS, when I enable it from a disabled state from BIOS it takes the system to power down and power back up to have the ethernet but the same story ensues with Device Manager. There is one thing I do want to note, the Green power LED for the NIC is always on and has been that way ever since it was handed to me for repairing. Does that indicate anything? The green power LED on the NIC is apparently well lit even though I have it disabled in BIOS.

                     

                    * Thank you for the assist btw, it means a lot to me

                    • 7. Re: Intel 82566DC-2 not functioning, questions
                      N.Scott.Pearson

                      There are two LEDs on the RJ-45 connector. The left-hand (green) LED is the LINK indicator. It will be off if no link can be established, lit if a link can be established or blinking if activity is occurring. If it is always on when no CAT5/6 cable is plugged in, something has definitely failed in the hardware. Normally, with it plugged into an active network, it should be blinking with activity. Not blinking when activity is for-sure occurring is another indicator of a possible failure in the hardware. The right-hand (green/yellow) LED is the RATE indicator. It will be off for 10Mb connection, lit green for 100Mb connection and lit yellow for 1Gb connection.

                       

                      To put things in perspective, the current chipset is the 10 series. This board has a 3 series chipset. This means the board is 7 generations and 8 years out of date and is well beyond its (3 year) warranted lifetime and just beyond its (7 year) expected lifetime. I hate to say it, but things are going to be starting to degrade (if not outright fail) on the board -- and I am not just talking about the ICs; minor components like capacitors and resistors and even (or should I say especially) the solder connecting them to the board could be starting to degrade or fail. As well, the flex in the (PCI, PCIe, DIMM, etc.) connector pins will be starting to degrade, surface oxidation will be occurring, etc., all resulting in signal disconnections, etc. On top of all this, the older the board, the more compatibility issues it's going to have with newer hardware and software. Windows 10, for example, is not going to run on this board except through compatibility drivers, which don't perform anywhere as well as native drivers. It's probably time to be thinking about a replacement. As for this particular issue, there are lot so Gb LAN add-in cards around pretty cheap

                       

                      I wonder, was the WLAN dongle added because the LAN connection was not working?

                      ...S

                      • 8. Re: Intel 82566DC-2 not functioning, questions
                        Lutfij

                        Yeah, I've figured as much that's why I suggested we stick to Windows 7 Home Premium. I did off the reservations and suggest that she go for 8GB of DDR2 ram to populate all four of the motherboard's slots. Let's see if that takes precedence. With no cable plugged in the left hand LED stays lit but there is no indication of an activity on the right hand LED. I was thinking the same thing until it occurred to me that my friend might have gone for wireless to rid the crib of the unsightly wire across rooms

                         

                        As for newer hardware additions, It's been without a dedicated GPU for about it's entirety, heh. Do you reckon we close this topic and declare the NIC to be dead? I'd like to offer the same consolation to my friend as I'd like to deliver the system on a clear note.

                        • 9. Re: Intel 82566DC-2 not functioning, questions
                          N.Scott.Pearson

                          If the left-hand light is on without a cable attached, the interface is broken. Call it a loss and move on; you can tell them you made a valiant effort to save it but were not successful. If hardwired LAN (ever) becomes a must, US$9 (Amazon.com), will put a GB adapter into the machine.

                          ...S

                          • 10. Re: Intel 82566DC-2 not functioning, questions
                            Lutfij

                            Will do buddy!

                             

                            I'll see how the rest of the system holds up after a re-installation of OS and during delivery, I'll relay the help you folks have given me to come to this conclusion. Thank you, especially Scott, for helping me get by this unnerving issue. In fact I was exercising a search across USB driven LAN adapters to get by with wired connectivity. Regardless I'm very certain wireless connectivity will be her go-to solution on www consumption.

                             

                            If possible, I'd like to have this thread closed. The thread has been solved