2 Replies Latest reply on May 24, 2016 11:56 PM by monahanz

    Cannot find/load Eclipse

    monahanz

      I wish to develop C programs for the Edison breakout board.

      I cannot seem to find a location that will allow me to install the Intel Eclipse IDE to write and run C programs for it.

       

      I went through the Intel IoT download page to setup the Windows 64 “XDK’ and end up with an IDE that only contains NODE.JS , “Hybrid Mobile Apps” – whatever that is, and other stuff. Is there not a simple location just to download a C type IDE interface for the board.

       

      I spent/wasted, a lot of time reading “Installing the Intel® System Studio IoT Edition” from here:-

      https://software.intel.com/en-us/installing-the-intel-system-studio-iot-edition

      I went through the 7-zip download etc. but the was no “iss-iot-launcher.bat”  file anywhere in the end. 

       

      Surly in this day and age, there is a simple way to download an C development IDE for windows 10 for the Edison. What am I doing wrong?

      Suggestions please.

       

        • 1. Re: Cannot find/load Eclipse
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello monahanz,
           
          Did you download it from here: https://downloadmirror.intel.com/25871/eng/iss-iot-win_03-14-16.7z? If so, I found it very strange that you can't find iss-iot-launcher.bat. I just downloaded it and I was able to find it. Why don't you try to download it again?
           
          Remember that Windows 10 by default hides file extensions, you can follow this guide: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions#show-hide-file-name-extensions=windows-7 in order to show them.
           
          I've experienced some issues where I couldn't start the IDE unless I it was installed on C:\Windows\System32. However, decompressing the files there solved the issue. Why don't you try that? Also, remember to run it with Admin rights.
           
          Try this and let me know how it goes.
           
          Peter.

          • 2. Re: Cannot find/load Eclipse
            monahanz

            Thanks for the fast reply Peter.

            I spent some time today trying to get things to work.

             

            The good news is I re-did the download as you suggested. For some reason windows 10 would not let me put a zip file is \window\System32 folder. Probably for good reason.  Anyway I downloaded it to my browser general downloads folder and then made a folder C:\Intel\iss-iot-win in which I placed every file and folder from the expanded downloads folder.

            iss-io-launcher.bat was there this time!!!

             

            I ran as Administrator the batch file.  Got a popup saying wrong or no JDK. After a few tries (where I had to remove much old Java Development stuff),  I did manage to get everything loaded.

             

            Now I have to learn how to actually run the thing.  It looks like I have the WiFi connection to the Edison working so if I understand things correctly it will be able to run the code form my PC directly on the Edison board – very nice!

            John