1 2 Previous Next 15 Replies Latest reply on Jul 13, 2016 11:25 AM by N.Scott.Pearson

    dz87klt-75k struggle is real

    blackmoore

      sad to discover the end of intel's desktop boards was a reality. but regardless i wanted one to take that leap to 1150 since my 750 media series board is still going strong for a decade! almost went with EVGA or ASUS, but i found a single remaining dz87klt floating around on amazon with IO shield only. no boxes, software, or accessories. although it's bare bones for me this was a no brainer to sacrifice current generation to at least have an intel board... a board that's basically non existent... a ghost!

       

      it was a struggle just to even find one, and now it's more of a struggle to get it operational.

       

      got everything installed; i7-4771; 32GB 1600 RAM; 1TB HDD; 500w PSU; 1GB pci express card (since it was posting a video error)

       

      turn the machine on with OS disk it hangs on POST CODE "15" no splash

      run in bios mode using the red button i get POST CODE "EB" splash & menu are visible but keyboard is unresponsive (both USB & PS2)

      pull the bios jumper and try to emergency flash bios 336 with USB it hangs on POST CODE "06"

      if i try the exact same thing with bios 457 i think it hangs back on POST CODE "EB" or "15" again

      if i pull ram or drives on next boot it will text that it noticed a change, but i still cannot hit enter and proceed to bios.

       

      i had a similar issue with dp35dp trying to run a quad core, i had to reinstall core duo just to install a bios to recognize the quad core chip. however, all the processors in the compatibility list for dz87klt claim min bios "336"... is that what the board ships with? how could i update the bios if all the chips have same min bios? i feel like i'm taking crazy pills!

        • 1. Re: dz87klt-75k struggle is real
          Al Hill

          Personally, I would return it to amazon/seller.

           

          I have the same board, same processor, 4*1TB drives, 1*Intel 525 ssd, 910w power supply, evga graphics (and I also previously used the onboard graphics), 32gb ram, latest bios, and all works as it should.

           

          Also, what model video card are you using?  More specifics are always good and will help responders.

           

          Doc

          • 2. Re: dz87klt-75k struggle is real
            blackmoore

            thanks for the ultra fast response, the video card i popped in is evga 9400gt i keep around as a backup card. helpful in situations like this. the board was able to detect a bad drive earlier and put the txt when i was running hdmi. but without the video card i wasnt even able to get to the splash screen. everything seems to light up on the board correctly im just currently brick walled with bios i think. i dont even know what bios it's currently running...

             

            ill elaborate on ingredients:

            LG combo drive sata

            WD black 1TB 7200 sata

            32GB (4x8) 1600 DDR3 corsair vengeance pro

            500w PSU isn't "haswell ready" for c6-c7 sleep but i can change the sleep settings right? then change back when i get better PSU...

             

            either way im at a loss if i have to return the board, i cherry picked ram and processor exclusively for this build... gtx 970 wouldve been next purchase

            • 3. Re: dz87klt-75k struggle is real
              Al Hill

              Are you attempting any secure boot/uefi?  One thing that is a concern is that your 9400gt is not useable if you are attempting secure boot.  If you intend to use an add-on card, you must use something greater than a gt 640 (if I recall correctly).  The 700 and 900 series cards are good to go, but a 600 series card must be greater than a 640 and must have its firmware updated to support secure boot.  If you are not using secure boot, the 9400gt should be useable.

               

              I previously had 16gb of corsair vengeance memory, with no problems.  Currently, I am using crucial ballistix.  All of my hard drives are Seagate sshd.

               

              Are you saying that the onboard video did not work?  I would remove your add on card, and try to get the board to work with the onboard video and only one stick of memory, and one hd.

               

              There are several other forum members that have that board as well.  Perhaps they have more to offer.

               

              Report back.

               

              \Doc

              • 4. Re: dz87klt-75k struggle is real
                N.Scott.Pearson

                Yes, this is exactly the configuration to try. Let us know what happens...

                • 5. Re: dz87klt-75k struggle is real
                  blackmoore

                  ok. so i pulled the cmos battery let it sit over night and stripped down to bare bones; no card, 1 stick, 1 hdd, 1 dvd... even pulled usb header. still hangs on POST CODE "15" hdmi no splash. reboot with red bios button i get warning txt memory size decrease with POST CODE "EB" cant hit enter to continue, keyboard is unresponsive. pop in the graphics card i can get to the splash with same post code but still cant access the menu. all lights are green on the board but i just can't crack this nut! noticed the SN# ends in 304 which suggests this board is c1 stepping? still have yet to install an OS so don't think i can tinker with uefi yet, but i do have a gtx 950 too if i decide to cross that bridge... contacted amazon seller to see what they know, currently awaiting their response.

                  • 6. Re: dz87klt-75k struggle is real
                    N.Scott.Pearson

                    Disconnect everything unnecessary. You should have only the keyboard, mouse and (HDMI) monitor cable plugged in. Power on with the Back-to-BIOS button pressed (lit). You should be able to use keyboard and mouse. If you cannot, try using different USB ports (on the back panel; nothing on front panel cables). If this doesn't work, there's likely something broken on the board...

                    • 7. Re: dz87klt-75k struggle is real
                      N.Scott.Pearson

                      Oh, and no add-in cards present (especially graphics)...

                      • 8. Re: dz87klt-75k struggle is real
                        blackmoore

                        ok did exactly just that, only essentials 1 stick ram + mouse & keyboard only... even unplugged hd audio.

                         

                        so using back to bios with jumper in normal position it hangs on "EB" and nothing reports thru hdmi.

                         

                        if i pull the jumper and reboot it hangs on "92" for a bit then hangs on "EB" hdmi reports WARNING: CMOS Checksum Error but enter to continue isnt an option like other messages, keyboard will light up but hitting capslock doesnt toggle the light.

                         

                        if i move the jumper to maintenance mode it has the same post codes but reports WARNING: Chassis Intrusion however numlock and capslock lights will toggle with noticeable delay... no option to continue.

                         

                        without the use of back to bios no warning txt is ever given and still hangs on "15" unless i pull the jumper then its "EB"

                        • 9. Re: dz87klt-75k struggle is real
                          Intel Corporation
                          This message was posted on behalf of Intel Corporation

                          Hi Blackmoore,
                           
                          I suggest you to download here the Technical Product Specification, page 71, “Overview of BIOS features”, it could help you.
                          https://downloadcenter.intel.com/download/22677
                           
                          Regards,
                          Hellen.
                           

                          • 10. Re: dz87klt-75k struggle is real
                            N.Scott.Pearson

                            Blackmore,

                             

                            What is the revision (AA) number for your board (it's on a sticker on the board along with the board's serial number)? According to the support site, it needs to be G74721-303 (which means stepping 3.03) or higher (newer) to support this processor. If it is G74721-302 (stepping 3.02) or older, there is a chance that it is not going to work with this processor. In fact, the board went to production at stepping 3.03. If the number is lower (older), it means that you've been sent a pre-production board and, well, all bets are off. If this is the case, a possible issue is the result of a pre-production BIOS. In this case, I would attempt to install the latest BIOS using the Recovery Method (where you insert a freshly formatted (FAT32 file system) USB flash disk, containing only the KL0457.BIO file, into one of the boards rear USB 2.0 ports (black), remove the BIOS configuration (yellow) jumper and power on the system)

                             

                            Hope this helps,

                            ...S

                            • 11. Re: dz87klt-75k struggle is real
                              Intel Corporation
                              This message was posted on behalf of Intel Corporation

                              Hi Blackmoore,
                               
                              Thought I would just check in and find out if you were able to find a solution for this, and if you tried Scott’s suggestion.
                               
                              Regards,
                              Hellen.
                               

                              • 12. Re: dz87klt-75k struggle is real
                                blackmoore

                                sorry to leave everybody hanging. like al hill originally suggested i was refunded by the amazon seller and during this time, amazingly found another board on ebay (AA 305)... this one worked as advertised! ran bios on first boot, dialed everything in, intel inside chime on the second boot and voila here we are! i might even go the extra mile and put in a custom splash...

                                 

                                the only minor problem im having now is windows 10 isn't allowing wifi connection for some reason. the supplimentary wifi/bluetooth module is recognized with up to date drivers but there's no option to connect with it in settings under network & internet.

                                • 13. Re: dz87klt-75k struggle is real
                                  Intel Corporation
                                  This message was posted on behalf of Intel Corporation

                                  Hi Blackmoore,
                                   
                                  Thanks for the update, also this new issue you are getting on this Intel board, it’s a compatibility issue; here you can find the list of Supported Operating System DZ87KLT-75K: http://www.intel.com/content/www/us/en/support/boards-and-kits/desktop-boards/000005640.html
                                   
                                  Regards,
                                  Hellen.
                                   

                                  • 14. Re: dz87klt-75k struggle is real
                                    blackmoore

                                    yes it's definitely a compatability issue.

                                     

                                    and it appears a LOT of people experience wifi problems after windows 10. what i did was uninstall the 802.11bgn 1T1R wireless adapter in device manager then install the wireless 3.1.4 driver from intel's downloads for this board. but for some reason it continues defaulting to the MediaTek driver supplied in system32. so i had to manually update driver in device manager and then select the actual Ralink driver from that list to make it stick!

                                     

                                    NOW it works, but extremely weak and slow only 2-3MB max! so i install the motorola bluetooth driver and it takes, then bam 7-8MB max, but now there's no bluetooth options or utilities in widows 10. digging through forums nobody knows if motorola will update the driver. this is probably all old news and i'm just late to the party, but seriously this module is a technological turducken of a mess. it's by msi MS-3871 and requires 2 seperate drivers from 2 different parties, Motorola 2.1 EDR for bluetooth and Ralink RT2870 for the wifi.

                                    1 2 Previous Next