6 Replies Latest reply on May 30, 2016 2:49 PM by Intel Corporation

    Intel NUC DE3815 XHCI settings an Linux

    Joe006

      Hi!

       

      I finally installed CentOS 7 on my NUC and when I enable XHCI in UEFI setup, the system freezes at shutdown/reboot.

      At boot, I can see the following line: "ehci-pci 0000:00:1d.0: port 1 reset error -110"

      This happens every time if XHCI is enabled in BIOS. It does not matter if there are USB devices connected or not.

      Currently I am using BIOS 0049 (latest) on this Bay Trail based NUC and all available updates to CentOS.

       

      I installed CentOS with this guide: e_MMC install on intel NUC DE3815TYKHE - CentOS (posts 7 and 9)

       

      Here is some additional information: https://www.spinics.net/lists/linux-usb/msg112624.html (Bay Trail)

      Setting XHCI to Enabled/Disabled solves the problem: 14.04 - Ubuntu booting error: ehci-pci 0000:00:id.0: port 1 reset error -110 - Ask Ubuntu (Acer Aspire E15 Start - Bay Trail)

      BIOS-Update solves the problem: https://bbs.archlinux.org/viewtopic.php?id=208982 (Intel Celeron J1800 - Bay Trail)

       

      If I unbind the ehci-pci driver, the system freezes. It doesn't even respond to ping.

      If I use "lsusb -vv" it stops at "Bus 003 Device 002: ID 8087:07e6 Intel Corp." and freezes.

      if I use udev to remove the PCI device, the system freezes.

       

      This phenomenon should only happen if XHCI is set to Auto or "Smart Auto".

      But I can only set it to Disabled or Enabled. It is clear that this setting is mislabelled as "Enabled", but it should be "Auto".

       

      Please correct this issue in BIOS, rename "Enabled" to "Auto" and add a real "Enabled" option.

       

      Best Regards,

      Joe006