3 Replies Latest reply on May 24, 2016 8:29 AM by Intel Corporation

    i5-5300U doesn't get lower than 800Mhz for saving energy

    Robeam

      Hello,

      I have a Dell notebook (XPS 13, Model 2015) that has a Broadwell CPU i5-5300U.

       

      All seems to run fine. But one thing that I don't understand is why the lowest possible CPU clock of 500Mhz (multiplier 5x) is never reached. The CPU never goes below ~800Mhz (8x) even when the CPU is idling. That way the CPU never reaches its full potential of energy saving.

       

      I have tried several power settings on Windows 10, also the tools by Dell and bios/UEFI settings, but even a plain fresh Windows 8 installation shows the same result. Whatever I do it gets never lower than 800.

       

      So what's wrong here? Maybe it's a Broadwell feature that I don't know of. Or there is a hardware/software issue related to Dell but unfortunately their support isn't a good help at all. Unfortunately I also haven't seen any topic about this on the net.

      I know several older notebooks of the Haswell generation (e.g. i5-4500U) which perfectly reach their lowest ratio at 500Mhz. Even desktop CPUs can do it so what can be possibly wrong?

       

      Thanks,
      Robin