6 Replies Latest reply on May 27, 2016 9:47 AM by Intel Corporation

    Blocking connect to SSH via wifi (by router)

    CrazyDev

      Hi all!

       

      I can't connect to Edison via wifi (blocking by router. It happens usually on free wi-fi points, at home/work - all work fine).

       

      And I need work with host port (USB webcam). All what I want - upload my code in Edison. But with working host port - I have only serial port for connect to Edison. I can work via terminal, but develop programs.... - arrrrgggh)))

       

      May be exists any solution for my problem?

        • 1. Re: Blocking connect to SSH via wifi (by router)
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi,

          How are you connecting your device to the open WiFi networks? I suggest you to use configure_edison --wifi and then chose option 2 for “Manually input a hidden SSID” and then select the correct option for the type of network. Are you connecting the board using another method? Please let us know if you are receiving an error message or something similar that would help us to identify the problem.

          Regarding the problem with the host port:
          1.    Are you installing the required drivers?
          2.    Are you able to see the video0 device on /dev?
          3.    Are you using the Arduino Expansion Board or the Breakout Board?
          Please let us know about how are you connecting your webcam and the errors you have. Take a look at: https://github.com/drejkim/edi-cam it will help you with this.

          Regards,
          Charlie

          • 2. Re: Blocking connect to SSH via wifi (by router)
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Hi,

            I would like to know if you have tried to connect your board to the open networks using the suggestions above. Also, did you check the edi-cam tutorial? Are you able to see the video0 device in /dev?

            Regards,
            Charlie

            • 3. Re: Blocking connect to SSH via wifi (by router)
              CrazyDev

              Hi!

               

              1.    Are you installing the required drivers? - YES

              2.    Are you able to see the video0 device on /dev? - YES

              3.    Are you using the Arduino Expansion Board or the Breakout Board? - Arduino Expansion Board

               

              Problem not with video. Problem with connect via SSH when I use some (not all) wi-fi points. I can "ping" Edison, but can't connect SSH (also, I tried use 80 port, useless).

              I can connect when center USB connected (10.0.2.15). But when I connect USB camera - I need switch relay to "up" position. And Ethernet via USB going down.

               

              I suggest you to use configure_edison --wifi and then chose option 2 for “Manually input a hidden SSID” and then select the correct option for the type of network

              configure_edison --wifi, but I choose open network. Then I can successful ping Edison, but cant connect via wi-fi..

               

              May be exists solution Ethernet through Serial?

              • 4. Re: Blocking connect to SSH via wifi (by router)
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hi,

                Why are you trying with port 80, for SSH you should use the 22. Have you verified that the problem when you are not able to connect your board through SSH is not the network itself? Are you sure that the problem is not related with the strength of the network?
                Are you checking the /etc/wpa_supplicant/wpa_supplicant/conf file? 
                While having problems to connect the board through SSH, do you check the SSID that the board is currently using? Commands like the following will help you:
                configure_edison --showWiFiIP
                ifconfig wlan0 | grep -e "inet addr"


                Try also by editing the /etc/resolv.conf with your DNS.
                Unfortunately, there isn’t a Ethernet through Serial solution that we could use for your case.

                Regards,
                Charlie

                • 5. Re: Blocking connect to SSH via wifi (by router)
                  CrazyDev

                  Why are you trying with port 80, for SSH you should use the 22

                   

                  I thought port 22 was blocked. Because I could open the settings page of Edison by 80 port. I change port to 80. And I can connect to SSH with port 80 now but not in all wi-fi points

                  • 6. Re: Blocking connect to SSH via wifi (by router)
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                    Hi,

                    Did you check the files I mentioned above?
                    I suggest you to check all these files and try to see if there is a network conflict when you are not able to ssh while connected to the wifi point.

                    Regards,
                    Charlie