9 Replies Latest reply on May 19, 2016 10:07 PM by bmv

    Issue with connman after reboot

    KyloRen

      A friend of mine is trying to setup connman on yocto 3.0 and having an issue with connman not working after reboot. Steps to repro:

       

      Setting up connections works first time:

       

      root@edison:~# connmanctl

      connmanctl> services

      *AR cadsfb               wifi_fcc2de344121_636164736662_managed_psk

          EY                   bluetooth_984FEE03DEAE_78FD941A39A0

      connmanctl> agent on

      Agent registered

      connmanctl> connect bluetooth_984FEE03DEAE_78FD941A39A0

      Connected bluetooth_984FEE03DEAE_78FD941A39A0

      connmanctl> exit

      root@edison:~# ping google.com

      PING google.com (172.217.3.46): 56 data bytes

      64 bytes from 172.217.3.46: seq=0 ttl=53 time=52.025 ms

      64 bytes from 172.217.3.46: seq=1 ttl=53 time=142.419 ms

      64 bytes from 172.217.3.46: seq=2 ttl=53 time=60.363 ms

       

       

      After reboot:

      Poky (Yocto Project Reference Distro) 1.7.3 edison ttyMFD2

       

      edison login: root

      root@edison:~# connmanctl

      connmanctl> servicees

      Error 'servicees': Unknown command

      connmanctl> services

      connmanctl> scan wifi

      Error getting services: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.conError getting peers: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.connmaError getting technologies: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was brokenError: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

      Error /net/connman/technology/wifi: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

       

       

      I have not seen this error on my instances, any hint?

        • 1. Re: Issue with connman after reboot
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi,

          I haven’t been able to replicate the same issue. Are you using connman 1.27? Please let me know if something else has been installed or modified in the image.
          Also, have you tried with disable wifi and enable wifi while using the commanctl command line?
          Is this also after being connected to a wifi network? I saw you are using the bluetooth_984FEE03DEAE_78FD941A39A0 service.
          Is the board only using connman? Or it was also connected using configure_edison --setup?
          Are you doing changes in the /var/lib/connman/settings file?

          Please let me know as much you can regarding this case so I could try to replicate it.

          Regards,
          Charlie

          • 2. Re: Issue with connman after reboot
            KyloRen

            Thank you Charlie,

             

            Like you I haven't been able to reproduce, but this has happened 3 times on his side, I asked him to respond. But here is what I know:

             

            • Not sure if he tried disable/enable wifi, we can try that.
            • Both Bluetooth and wifi works first time after configuring connman
            • Not sure if any changes been made manually to /var/lib/connman/settings

             

            Thank you for support, will keep you posted.

            Ali

            • 3. Re: Issue with connman after reboot
              bmv

              Hi Charlie,

               

              Thank you for your help on this.

               

              To answer your questions:

              • I tried disable / enable wifi with no effect. 
              • I had used configure_edison --setup previously but just retested without doing this and got the same effect. 
              • I made no change to /var/lib/connman/settings
              • I've tested on two different edison's and have the same problem

               

              Edward

              • 4. Re: Issue with connman after reboot
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hi Edward,

                Try by restarting the services for wpa_supplicant and connman with:
                systemctl restart wpa_supplicant
                systemctl restart connman

                I’ve been able to obtain some issues, but not yours yet (restarting the services solves the problems in my case), let me know step by step what you are doing so I could replicate it starting with a fresh new flashed image on the board (https://communities.intel.com/docs/DOC-25154).
                Also, post a screenshot of the status of connman and wpa_supplicant service (systemctl status wpa_supplicant && systemctl status connman)
                While the board is booting, have you seen errors while loading a service or does everything looks OK?

                Kind regards,
                Charlie

                • 5. Re: Issue with connman after reboot
                  bmv

                  Hi Charlie,

                   

                  Okay it even gets stranger. Looks like the problem is intermittent which is really strange.  Attached is a log of everything I did on a board already set up that worked once yesterday but then showed the strange behavior on reboot.

                   

                  Dropbox - command_example.txt

                   

                  As you can see, the first time I logged into today, it worked like magic.  Then I simply rebooted and it no longer worked. I tried the systemctl restart wpa_supplicant and systemctl restart connman but it didn't help.

                   

                  Edward

                  • 6. Re: Issue with connman after reboot
                    bmv

                    After multiple tests, I can confirm that sometimes everything works perfectly after a reboot and other times it gives the error previously mentioned with no changes to the system other than rebooting it.

                    • 7. Re: Issue with connman after reboot
                      Intel Corporation
                      This message was posted on behalf of Intel Corporation

                      Hi Edward,

                      I would like to know if you have tried with a previous release, just to check if happens the same, if doesn’t we could use it as a workaround: http://downloadmirror.intel.com/25384/eng/edison-iotdk-image-280915.zip 
                      I saw the log you posted and is indeed very odd. As you can see, when you run services, it doesn’t show the HWaddr on the hashA (wifi_000000000000).
                      When you run ifconfig, are you able to see the HWaddr? Please post a screenshot of what you get when running ifconfig.
                      Before using connmanctl, always check the status of the connman and wpa_supplicant services, once on connmanctl, run enable wifi, scan wifi, services, agent on and finally connect; this in order to avoid problems in the connection.
                      Let me know about the HWaddr, and the results of testing with another release.

                      Kind regards,
                      Charlie

                      • 8. Re: Issue with connman after reboot
                        KyloRen

                        Hi guys, I just reflashed  our new Intel Edison with yocto 3.0 and configure connman, connman worked post several reboots. Here is what I did:

                         

                        1) Flash the Edison

                        2) Logged in via Serial

                        3) Ran configure_edison --setup (Didn't configure wifi)

                        4) systemctl stop wpa_supplicant

                        5) systemctl disable wpa_supplicant

                        6) systemctl enable connman

                        7) systemctl start connman

                         

                        and configure a wifi connection to our home AP

                        • 9. Re: Issue with connman after reboot
                          bmv

                          Hi Charlie,

                           

                          This older release seems to be working fine on the first edison.  Thank you for the help.  I'll continue testing on my other edison and let you know if I continue to have issues with this older release.

                          1 of 1 people found this helpful